Support » Plugins » Podpress 8.8.4 won’t work

  • I have installed the podpress plugin version 8.8.4 on my wodpress 2.9.2. I am using media temple to host. I have uploaded my podcast mp3 files to wp-content/uploads then when I make a post I choose the file and make the post. The problem is the plugin shows up in the post but when I play it just says “Loading….” and doesnt do anything. I am new to wordpress and podpress and any help would be greatly appreciated..

Viewing 14 replies - 1 through 14 (of 14 total)
  • Have you activated the statistic functionality of podPress?
    If you have done this use a permalink structure which is different then the default one. Go to Site Admin > Settings > Permalinks and choose e.g. “Day and name”. After you have activated a non-default-permalink structure the main blog folder should contain a file with name .htaccess.
    Deactivate and activate the stats functionality of podpress when this file is place. That all should solve your problem.

    If my assumptions are correct then deactivating the stats function should work (for testing purposes) also.


    I am having the same issue.. was this ever resolved? Podpress Version 8.8.4 with WP version 3.0


    Do you use the statistic functionality? Or not?
    The problem which was described in the first post can have many different origins.

    One of them is that if you want to us the statistics of podPress and you have activated the recommended method “use wp permalinks”, you have to use a permalink structure different from the default. It is also recommended to update the permalink settings after you have installed (or updated) podPress.

    Another reason might be that you are using eventually non-ASCII characters in the file names of your podcast files. podPress 8.8.4 (and older) can not handle such file names.

    These are probably the two most likely cause for the described symptoms.
    But if the cause for your problem with podPress in your blog is different one then it would be helpful know which functions of podPress you are using and e.g. whether your WordPress Address is different to the Site Address or whether your blog is installed under a subdomain.
    Since when have you these problems? Have you installed other plugins recently?

    Or did the problems start with WP 3.0?

    … this is of course another important point. podPress 8.8.4 does not work completely with WP 3.0. There might be no problems or error messages during the installation in a WP 3.0 blog but e.g. the way podPress tries to retrieve the uplooads/-folder does not work.

    So, if you do not want to make a rollback to WP 2.9.2 then you could try out the latest Development Version of podPress. If you experience problems with this Development Version then please post your report in the podPress and WP 3.0 or the [Plugin: podPress] podPress 8.8.5 beta testing thread.


    I didn’t have the Statistics enabled initially, I have since enabled them and am using this custom structure for permalinks: /%postname%/

    my entire site is WP so no differing address issues…

    I just installed the podpress plugin after we upgraded to WP 3.0 — am new to podpress first time using.


    my entire site is WP so no differing address issues.

    I’m sorry. I have asked probably not the right question. I meant: Are the values Site address (URL) and WordPress address (URL) on the general settings page of your blog the same or not?

    But in each case I would say that you should try the Development Version of podPress. This Development Version is probably already more stable in WP 3.0 than the older versions.

    Ahhhh… yes the Site/Wordpress URLs are identical. I guess we will try the Development version or just disable the player all together since the button below works fine…


    Upgraded to Development version and still having the same issue… 🙁 can’t get the player to work, simply says buffering…

    What result has the Stats Test on podPress general settings? (… and does the player work when the stats are deactivated?)

    When I run a stats test I get the following message: Test: Successful

    I deactivated the stats reporting and the player still does not work. I installed the plugin (v8.8.4) on a different WP installation (same server/host) — WordPress 2.9.2 thinking it may be WP v3.0 that is causing the issues — however I am having the same problems with the plugin on this installation as well.

    The player does not work, when you click play it says buffering, the bar colored status bar goes all the way to end as if it is buffering (and buffering is complete) however the audio never plays. If you click on the MP3 button below the player — the audio plays just fine (however it does open up another window and plays it using the QuickTime player.

    Would really like to use the podpress player if at all possible – any ideas what the problem could be?

    That is a good report! But I still have to guess what the reason for the problems might be. That is why I have some more questions for you:

    I discovered that I have not asked you which player you are using in your blog? 1PixelOut or Podango player?

    Please try both. Exists the problem with both? Or occurs the problem only with the 1PixelOut player?

    v8.8.4 and v8.8.5 (beta 14.1) include different versions of the 1PixelOut player. The player is from the latest version of a different WP plugin (and the maker of the player) and in the support forum are posts which point out that this problem is eventually related to the web browser.
    Does the player work if you try with a different browser?

    The requirement of this player is at least Flash Player 9. Is the latest Flash Player installed on your computer?

    If you are testing with Firefox then deactivate temporarily the ad-blockers if you have such add-ons.

    Another important thing is to find out whether there are Javascript errors during the loading process of your page. Most browsers have such a error console where errors and warnings are listed. For instance Firefox has one.

    ntm, I tried both players have been using the 1PixelOut for most testing. I have the latest Flash Player, tested with both Firefox and IE with the same results.

    What I did do was try one of those sample MP3 files that come with some audio software and it worked just fine, so apparently there is something wrong with the way we are generating our MP3 files that is causing the problem – I just don’t know what.

    Thanks for all of your help.

    @mrsrjp flash doesn’t support all MP3 formats and since the 1-pixel out player (and others) use flash, they don’t either.

    I use Audacity to creat MP3s and so I ran into this problem with older versions of Audacity:

    If you want to correct your existing MP3 bitrates and vbr/constant settings try using LAME as follows (see “Converting Existing MP3 Files” at the end of this article):

    Hope it helps,

    My mp3 audio files are never included in the permalinks…

    The podcast players always work on the main page, but never in the post permalinks.

    What is the solution? I’m using PowerPress audio player.

    How can I get my audio podcast player to be copied to the permalinks?

    Thanks to whomever knows the answer in advance!


    Steve, if you are using PowerPress then I would suggest to open a new thread and to add the tag “powerpress” to it. I’m sure that if you do that someone who knows PowerPress will answer your question.

    This thread seems to be about a problem which is related to the Permalink settings and the Statistic method of podPress. But the problem and the solution had nothing to do with these settings.
    I believe it would be a good idea to start a new thread. Name the plugin, the version of the plugin, the WP version and use the name of the plugin as a tag of this post. If this problem is related to podPresss (and not to Powerpress) then it would also be a good thing if could post the URL of the new thread here.


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Podpress 8.8.4 won’t work’ is closed to new replies.