Support » Plugin: PowerPress Podcasting plugin by Blubrry » Podcast Feed Not Validating

  • Resolved joelrendall

    (@joelrendall)


    I love PowerPress, thanks for your hard work and contribution to the community over the years!

    Lately I’ve been having some problems that I think are server related, but my host (Siteground) isn’t able to help since I don’t know the right things to ask.

    Feed: https://www.practiceportuguese.com/feed/podcast/

    There are lots of episodes in the feed so here is a shorter one with just one item for testing purposes: https://www.practiceportuguese.com/tag/podcast/feed/

    Here are the symptoms:

    • Although my podcast appears in iTunes and shows as “active” in iTunes Podcast Connect, iTunes doesn’t let you subscribe or listen to any episodes. No error, it just does nothing. As far as I can tell, this is happening for everyone. https://itunes.apple.com/ca/podcast/practice-portuguese/id599326719?mt=2

    • Despite the issue above, the feed *does* seem to work in some iOS apps: Overcast, Apple’s Podcast app… but PocketCasts on iOS and Android gives the error: “Too many follow-up requests: 21”

    • This podcast feed validator says my SSL cert is fine, but fails the “is it an rss feed” test, and all of the iTunes-related tests: https://podba.se/validate/?url=https://www.practiceportuguese.com/tag/podcast/feed/

    • This test *is* successful: http://castfeedvalidator.com/?url=https://www.practiceportuguese.com/feed/podcast/

    Based on a bunch of searching, I’ve gotten the following answers from my host, in case this is helpful:
    • They do not block HEAD requests
    • They *do* run nginx on their servers, (whatever that means!)

    Other notes:

    • The feed in iTunes does reference the https url to the feed

    • I’ve used the Blubrry premium stats service for many years, and currently use the https urls site-wide since switching to SSL over a year ago.

    • One thing I noticed is that when I look at other shows’ podcast feeds in Chrome, they display the xml with syntax highlighting and collapsible sections. But when viewing my feed, it just shows as plain text.

    • I have tested the feed on a staging site with default twentysixteen theme, with only Powerpress active and no other plugins, and it doesn’t seem to make a difference. (Just add staging2. after the www in the url to the feed links above, if it’s helpful for you to see that version).

    • I have the PowerPress settings that prevent other plugins from affecting the feed etc.

    • Since the topic is Portuguese, a lot of our descriptions have accented characters like é á ç ã etc. I’m not sure if that’s relevant or not?

    Thanks in advance for any help you can provide. I’m out of options and ready to pay for an hour of your consulting fee listed on your site if necessary.

    Cheers,

    Joel

Viewing 7 replies - 1 through 7 (of 7 total)
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Podcast Feed Not Validating’ is closed to new replies.