Support » Plugin: Seriously Simple Podcasting » Podcast feed is empty

  • Resolved bartini

    (@bartini)


    That’s it. After last automatic updates my podcast RSS feed is an empty file. Didn’t change nothing in plugin or wordpress code. Any reason?

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @bartini can you share the feed URL with us here so we can help look into this?

    I am having same issue. I’ve opened a case on your site as well.

    I have three feeds for two shows (Combined, TCP-Talks and TCP-Show) of those only TCP-SHOW is displaying correctly on Chrome.

    https://www.thecloudpod.net/feed/podcast (Combined – broken)
    https://www.thecloudpod.net/feed/podcast/tcp-talks (broken)
    https://www.thecloudpod.net/feed/podcast/tcp-show (Works)

    I was able to roll this back to 1.20.13 and this resolved the issue for me. It definently breaks in 2.0.0 and is not resolved in 2.0.1

    I’ve got the same problem:
    https://www.davechimny.com/feed/podcast

    But it’s not broken at all: The XML-Code is there, it just cannnot be shown as a webpage, because there seems to be a problem with the feed-stylesheet.xsl.

    Chrome Developer Tools:

    Resource interpreted as Stylesheet but transferred with MIME type application/xml

    • This reply was modified 10 months, 1 week ago by Dave Chimny.
    • This reply was modified 10 months, 1 week ago by Dave Chimny.
    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi all,

    We released an update to the plugin which should resolve this issue for you. Please update to v2.0.2 and see if this fixes the issue you were seeing. May have to clear server/browser cache and hard refresh your feed page to see the changes.

    Please let us know how it’s looking from your side after the update.

    I’ve already updated to 2.0.2 before and it’s still a white screen. 🙁

    I tried it in Firefox:

    XML-Verarbeitungsfehler: nicht wohlgeformt
    Adresse: https://www.davechimny.com/feed/podcast
    Zeile Nr. 86, Spalte 43:

    Not well formed. It points on an “&” character in the <itunes:summary> line. After changing it in this item, the error comes when the next “&” appears in the next feed item.

    Maybe that helps?

    • This reply was modified 10 months, 1 week ago by Dave Chimny.

    I upgraded 2.0.2 it fixed the two shows, but not the combined feed.

    Plugin Support Eileen Violini

    (@itsjusteileen)

    Hello @jbrodley,
    Thanks for letting us know. We have noticed some caching issues for this update. Can you try these steps and let us know if they get things working on your site.

      Deactivate and uninstall the SSP plugin.
      Clear your site and browser cache.
      Reinstall version 2.0.2

    Try this and let us know the results you have on your site.

    FYI: 2.0.3 didn’t change anyting. Still the same “not well formed” error.

    I read that an “&” can make problems in XML and therefore it should be enclosed in CDATA-tags. So I reverted back to 2.0.0 and had a look, why it’s working there.

    Guess what:

    <itunes:summary><![CDATA[...]]></itunes:summary>

    FYI: I used the ssp_feed_item_itunes_summary filter for adding the CDATA tags around the content of <itunes:summary> and then everything works in 2.0.3 as it should.

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi @netzblogr

    Can I ask you, what do you have set as the Episode description under Feed settings for this feed, is it set to Post Excerpt or Post Content.

    The reason I ask is that the 2.0.3 update adds the <![CDATA[…]]> tags around the itunes:summary tag content, when the user has set Episode description to Post Content.

    Thanks

    Dave Chimny

    (@netzblogr)

    Hey @psykro,

    I’ve set it to Post Excerpt. When I tested Post Content, the CDATA tags appeared.

    Dave Chimny

    (@netzblogr)

    2.0.4 fixed it!

    Plugin Support Eileen Violini

    (@itsjusteileen)

    Hello @netzblogr,

    The tags were added back in for the 2.0.4 release. Thanks for letting us know that this update fixed your issue.

    Cheers!

    Hello,

    I have two different websites that I had this happen to, the RSS feed all of a sudden is blank and my content is not pushing out to the regular podcast platforms. Can someone help me fix this issue? I tried uninstalling and reinstalling but that didn’t work. I’m not sure what else I can do!

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Podcast feed is empty’ is closed to new replies.