Support » Plugin: SG Optimizer » PNGs Failing in Image Optimizer

  • Resolved grindbehind

    (@grindbehind)


    If I have “New Images Optimization” turned on, I cannot upload PNG files to my Media library. It just says “HTTP error” at the top of the screen.

    JPG files work fine.

    If I turn off “New Images Optimization,” then I can upload PNGs.

    I am using Version 5.1.1 of SG Optimizer and am on Siteground hosting.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Can you give me your site URL please? That’s not a normal behaviour, some other plugin is most probably causing it but I need to check it out to tell you more.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Closing this to no reply.

    Hello @hristo-sg, sorry–your initial reply didn’t make it to my inbox.

    The website in question is Crypto-ML.com.

    The behavior is still there as of now so I can reproduce it as needed.

    • This reply was modified 8 months, 2 weeks ago by grindbehind.

    Hi @hristo-sg,

    I got the same issue when I upload images.
    The website is https://ksjourney.life.
    And it’s work fine after I disabled ‘New Images Optimization’.

    WordPress 5.1.1
    SG Optimizer 5.1.1

    Regards,
    Yang

    • This reply was modified 8 months, 1 week ago by yanghungtw.
    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey,

    We are currently working for a solution.

    I will post a reply when we fix the issues.

    Regards,
    Stanimir

    igabesz

    (@igabesz)

    +1, SG Optimizer version 5.1.2, 768MB memory for WordPress

    Small PNG files (~15k) are processed properly, but the processing of larger files fails. Even for an 50k file the upload sometimes completes, sometimes fails at ~36sec.

    Please fix this issue.

    • This reply was modified 7 months ago by igabesz. Reason: some details
    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey all,

    We’ve fixed the issue in 5.1.3 and PNGs bigger than 500k won’t be optimized.

    Please update to latest version.

    Regards,
    Stanimir

    I still have this issue with asd-usa.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.