Support » Plugin: WebP Converter for Media - Convert WebP & Optimize Images » PNG extension checkbox seems broken

  • Resolved alucardhs

    (@alucardhs)


    Png checkbox in the Plugin seetings doesn’t seem to work correctly. I can check and uncheck jpg and jpeg just fine, but if I try to uncheck .png extension, I immediately get an error: “Server configuration error. Redirects on your server are not working. Check the correct configuration for you in the plugin FAQ.”

    Upon checking the .htaccess file, the PNG-related sections are not removed. I have to manually remove them via ssh to my website. With jpg/jpeg everything works as expected and I get no errors.

    To that note, and let me know if I need to create a separate thread for it, the png images seemed to have converted incorrectly, losing the transparency. Is that expected?

    • This topic was modified 1 year, 1 month ago by alucardhs.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @alucardhs,

    Thank you for your message.

    What version of the plugin are you using? Can you send me some original PNG files which get corrupted after conversion?

    Thread Starter alucardhs

    (@alucardhs)

    Hi Mateusz,

    The plugin version is 1.4.5. Here’s one of the pngs that got busted: https://sunsetobsession.com/wp-content/uploads/2020/09/sunsetobsession_800_white.png

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @alucardhs, thank you very much for information. I released an update that fixes the problem with the format .png and misconfiguration on the server. You can download it now.

    In the case of converting a .png file on my environment does not have this problem. I believe this depends on the version of PHP libraries that the plugin uses on your server.

    Are you using the GD library? Are you able to use Imagick or do upgrade of GD library?

    Thread Starter alucardhs

    (@alucardhs)

    Hi Mateusz,

    Thanks a lot for a quick turnaround on this. I’ve installed the latest version and the checkbox issue is now fixed. Much appreciated.

    For the PNG, I am indeed using GD library. It is bundled with PHP and from what I can tell I’m running the latest version of php. For some reason, Imagick option is always disabled for me in the plugin settings, although it looks as if it is installed on the server (likewise, the server Configuration button in the plugin reports that it’s there: imagick module enabled | imagick module version 3.4.4):

    $ php -i | grep 'GD\|ImageMagick'
    GD Support => enabled
    GD headers Version => 2.3.0
    GD library Version => 2.1.1
    Imagick compiled with ImageMagick version => ImageMagick 6.8.9-9 Q16 x86_64 2019-11-12 http://www.imagemagick.org
    Imagick using ImageMagick library version => ImageMagick 6.8.9-9 Q16 x86_64 2019-11-12 http://www.imagemagick.org
    ImageMagick copyright => Copyright (C) 1999-2014 ImageMagick Studio LLC
    ImageMagick release date => 2019-11-12
    ImageMagick number of supported formats:  => 205
    ImageMagick supported formats => 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FITS, FRACTAL, FTS, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, JBG, JBIG, JNG, JNX, JPEG, JPG, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @alucardhs The Imagick option is disabled in the settings because although you have this library installed, there is no WebP format on the list of supported formats.

    Thread Starter alucardhs

    (@alucardhs)

    Yes indeed. After looking into it, I think fixing that particular issue is more trouble than it’s worth. I guess I will have to live with pngs switched off for now.

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘PNG extension checkbox seems broken’ is closed to new replies.