• Resolved Ewa


    The plugin is blocking my admin login page since the last plugin update. When I deactivated the PMPro plugin, the admin login page works. Could anyone let me know how to fix this problem, please? Any help would be greatly appreciated.
    Thx a lot

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Andrew Lima


    Hi Ewa,

    Thank you for reaching out to Paid Memberships Pro.

    You are able to use the /wp-login.php URL as we do not redirect away from this.

    If you do not need the frontend login functionality of Paid Memberships Pro, you may set your Log In page (under the Paid Memberships Pro page settings) to be “Use WordPress Default” which won’t redirect away from other login pages.

    I hope this helps clear things up.

    Hello PMPro team,
    I have a similar question.
    Issue is not with /wp-login but with /wp-admin/.
    Any attempt to /wp-admin/ receives a 302 + location = https://<domain>/login/?redirect_to=https://<domain>/wp-admin
    I cannot use /wp-admin/ login unless I disable PMPro.
    Maybe this is interference with another plugin but I can’t find it.
    Would you let me know where in PMPro code this redirection is handled, so I can investigate more?
    Many thanks,

    Plugin Author Andrew Lima


    @o_live when setting the Log In Page in Paid Memberships Pro, this will redirect wp-admin (but not the wp-login.php).

    To prevent this redirect entirely, you can set the log in page in Paid Memberships Pro to “Use WordPress Default” which will stop the redirect.

    I hope this helps clear things up.

    Hello Andrew,
    Thank you.
    As suggested, I set the login page in PMP to “Use WordPress Default”.
    Admin login is back to classic WP login page.
    But so is the user login.
    Any hook I could use or code I could modify to have classic WP login page for wp-admin only?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.