Support » Fixing WordPress » Plugins.php not found

  • Everything was working fine. Today when I logged into my WordPress dashboard, it notified me that some plugins needed updating. I selected the first one, Akismet, and clicked the automatic upgrade (I’ve done this before, no problems). This time, at the point where it would usually say Plugin Successfully Reactivated, it instead showed a portion of a 404 error page.

    Now, my Plugins page is broken. When I click on “Plugins” in my left sidebar, I get a 404 page not found error for plugins.php (Yes, the wp-admin/plugins.php file is still there.) It also no longer shows updated plugins count in a circle.

    Did the plugin itself get corrupted? Well, deleting Akismet folder made no difference, at least. Deleting ALL of my plugins does make the plugins.php page re-appear… but as soon as I add one plugin (any), the error returns.

    Researching similar problems here on the forums didn’t help: for example, for some other people, plugins.php not loading means sometimes a memory issue — but attempting to change the php memory limit via .htaccess file just generates a 500 server error for me, breaking everything. (PHP version is 5.2.10.)

    This problem did not/has not effected other WordPress installations on my server. (Though they are add-on domains and this one is a subdomain.) It also only seems to be related to plugins.php — everything else on my site seems fine, plugins all seem to be working normally, etc.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Not sure if this is related, but plugin-install.php as stopped working as well — all pages are blank, except for the start page (but the “popular tags” aren’t appearing at bottom.) This is occurring on other WordPress installations on my server now as well.

    I’ve had this as well. Everything looked fine until I uploaded a new plugin. Couldn’t do it through the admin panel, had to go the ftp route – and then once it was uploaded (not even activated), everything went pear-shaped.

    It’s happening across all my sites, but only if I change something… upgrade a plugin, try to add a new one. And it has happened on both 2.8 and 2.7.1.

    Alright, if no one knows how to fix this — can anyone recommend how I can reinstall or otherwise recover my blog without losing anything? I haven’t got a backup of the database. Is it possible to delete the plugin settings without deleting the blog?

    See if removing the plugin folders helps…

    wp-content > plugins > folders

    Copy them, put the copy somewhere for safe keeping, then delete the plugins folders (everything under plugins, not the “plugins” folder itself)…

    Does that help? The fact your plugins are removed doesn’t matter for the moment, just want to know if that helps with the problem?

    Yes, did this. When all plugins were removed, the plugins.php page loaded and disabled them all when it didn’t find them. However, if I put any plugin back into the folder, plugins.php fails to load again… even hello dolly, and even though it’s disabled.

    I was seeing what appears to be the same problem. Currently running WP 2.7.1 on Ubuntu (was going to upgrade but ran into this issue first).

    I was writing down how to reproduce the problem, but now I can’t … so is this a possible solution?


    1. rm -rf askismet from the plugins directory
    2. WP Admin > Plugins > Plugin Browser/Installer
    3. Search for Akismet and install using FTP installer
    4. Installation succeeds: directory created, same permissions as others in plugins, everything looks good
    5. Activate. It works.

    So I am pretty sure this didn’t work, and wp-settings.php was failing on the include_once function on line 473 … which doesn’t make sense since this is only done after a check that the file exists and so on. Bizarre.

    Yes, did this. When all plugins were removed, the plugins.php page loaded and disabled them all when it didn’t find them. However, if I put any plugin back into the folder, plugins.php fails to load again… even hello dolly, and even though it’s disabled.

    How about the entries in the database for plugins….

    There are a few in the options table, then there may also be (depending on plugins) extra tables in the database. If a problem resides in the tables, then it may not be a problem with file code per say, but with a corruption in left over entries in the DB…

    Check your tables, see if any are in need of repair…

    I could be totally off the mark here, but there’s no mention above of you dropping or examining anything in the database… so perhaps worth a mention… 🙂

    How would I go about doing that? For what it’s worth, I ran a check and repair of the database on my hosting control panel, but no change.

    Create a copy of your site locally, confirm if the problem carries over, if it does not then the issue is the server itself (could be just about any number of things if that’s the case)…

    XAMP, WAMP, MAMP, Uniform Server, take your pick…

    Process of elimination…. don’t assume anything…. 🙂

    I have the same issue. I don’t know what to do anymore, I basically tried everything. Does anybody have a solution to this? I really need to work with my plugins, and it would be great if someone knows a workaround or a fix to this bug.

    I have the same problem updated plugin now all I get is an error 401 page no longer exists if I try to access my plugin page in dashboard. I take it there is no absolute answer on how to fix it? I have tried swearing and pleading, but nothing seems to work. I don’t understand anything other than the basics so if anyone knows how to fix this could they post it in very childlike terms suited to a technical idiot please.

    OK Problem solved! We run multiple blogs and we were VERY careful to check that the uninstall, export and import were from the correct domain. If you get it wrong the damage may be permanent. It’s a bit off crossed-fingers situation and you will have to reload themes, widgets, plugins, but it’s all automated, so:

    1) Make a note of all widgets, plugins, themes, etc you are using. You will end up with a completely clean relaunch of your blog WITH ALL POSTS AND COMMENTS INSTALLED! If you have specific code/text in widgets, you can copy and paste it into a text editor on your pc.

    2) On dashboard, export your blog contents as an XML file to your pc.

    3) We use hostpapa, so the instructions here are for their service. Your webhost will probably be slightly (or vastly) different, but some option must available to achieve the following: Open your webhosting control panel, select Fantastico, then click on WordPress on the lists on the left. This will offer you the option of removing/uninstalling WordPress – do so!

    4) You then need to return to the control panel and click on Fantastico and click on WordPress again – this allows Fantastico to update itself with the removal of WordPress. It will therefore offer you the chance to put WordPress on as a new installation – do so!

    5) You will be asked for user name and password as you were when you first installed WordPress. Using the same name and password will prevent confusion in the future, but is probably contrary to the advice some security buffs would suggest!

    6) You can now log in to your dashboard as before. Just go check out those pages that didn’t work before! Now use the import option to bring back all your posts, comments etc. You can then start adding the themes, widgets, etc you used before. Beware, if one of those widgets caused the problem, it may well do so again. One happy side effect is that you have automatically upgraded your WordPress!

    A friend of Vamplit!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Plugins.php not found’ is closed to new replies.