Support » Plugin: User Role Widget Areas » Plugins works, but there is a blind passenger

  • Resolved kuroblack

    (@kuroblack)


    Hi Rob,

    I am using this plugin with twentythirteen theme. It works like magic, but this string “1\t\t” (\t as tab) showing.

    If I’m logged in, everything is ok, but
    If I’m NOT logged in, that string above is displayed in the place where “URWA-All Logged In Users” is.

    I will check again by disabling other plugins and using different theme.

    https://wordpress.org/plugins/user-role-widget-areas/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Alright, this “1\t\t” is shown if “Users-Logged In” contains a widget, but “Users-Logged Out” is empty.

    I “solved” this problem by adding a widget to “User-Logged Out”. Any widget might actually work, but I’m using an empty “Custom Menu Widget” as a dummy/invisible widget.

    Plugin Author Rob Smelik

    (@rob-smelik)

    kuroblack,

    Thanks for your comment. You are absolutely right. I installed a WordPress sandbox environment just a moment ago and loaded up the Twenty Thirteen theme and low and behold there it was. When I ran through all my pre-release testing I had placed a widget in that User-Logged Out widget area so this small bug was overlooked.

    As you mentioned the temporary fix is to throw an empty text widget or menu widget in that status based widget area and the error disappears. I am working on a permanent fix and will be sure to include it in the next release.

    Thanks!

    Rob

    Plugin Author Rob Smelik

    (@rob-smelik)

    Hi kuroblack,

    I just wanted to give you an update. I have re-written some sections of the conditional logic to account for empty widget areas. This eliminates the error that was being generated when widget areas were left empty. I am testing it in a handful of themes now including Twenty Thirteen. My plan is to push an update over the weekend.

    Cheers,

    Rob

    Plugin Author Rob Smelik

    (@rob-smelik)

    The plugin has been updated to address the issue mentioned in this thread. I am marking this topic resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugins works, but there is a blind passenger’ is closed to new replies.