Support » Fixing WordPress » Plugins won't update, install or search for new ones

  • I am having a weird problem. I can’t update, install or search for new plugins on my dashboard. When I try to upgrade Askimet, for example, it shows this message:
    Downloading update from…

    Download failed. Service Unavailable

    I get the same error “Download failed. Service Unavailable” when I try to add a plugin from the importer list.

    When I try to search for new plugins, I don’t get any results- only the result “An unknown error occured” no matter what I search for. If I click on the Featured or Popular links, I get a list, but when I try to install anything I get the “Download failed. Service Unavailable” message again.

    I tried deleting my uploads folder, and changing my permissions on my plug-ins folder to 777, but that did nothing. I also tried deleting the plugins folder and reloading a new one from the wp core. Nothing.

    Everything else on the blog is working fine.

    Please help!!


Viewing 2 replies - 1 through 2 (of 2 total)
  • just download the plugin from the plugin page and update the plugins through your ftp not through wp just overwrite all the files.

    Have these features ever worked before?

    Can you tell who the owner of the files and directories is (should be able to tell through ftp)? Is is the same owner? (I’m assuming a linux server here)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugins won't update, install or search for new ones’ is closed to new replies.