Support » Plugins » Plugins wont activate? (but say they do)

  • I decided to go back to 1.2 for a big project I’m working on, but testing locally (Apache/Win2k) plugins wont activate. They say they do, but they don’t (text is still “Activate” instead of “Deactivate” and features dont’ work).
    I searched the forums, couldn’t find a similar issue. Does anyone know what might be causing this? File permissions aren’t an issue since I’m on windows, so I honestly don’t know what’s up. I get the success message.. but alas, no success.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I just encountered the same problem in 1.2.1. The plugins appear to activate, they get bold and “activate” changes to “deactivate”, but nothing actually happens. (I tried Adhesive, todayAgo and nextPreviousDay.)

    OK, I did some more digging. From what I can figure out, the list of active plugins is supposed to be kept as a concatenated string in table ‘wp_options’, in a row called ‘active_plugins’. There is no such row in that table! Help!

    Was it a clean install or an upgrade ? If the later, it seems a few things were not done properly… Try to find what to put in the DB…

    It was an upgrade from 1.2, but I had not played with plugins then so I have no idea whether they worked or not.
    I have phpMyAdmin running, so I can easily add a row manually but I need to be sure that’s the right thing to do!
    Anyway, shouldn’t plugins.php barf loudly when it tries to update a row that does not exist? I get no error message at all, quite the contrary it returns with a success message!

    Mark (podz)


    Support Maven

    Try running upgrade.php again ?

    Is it harmless to rerun it? I’m clear on what it does exactly, there are so many functions that it would take me hours to trace everything, and I wouldn’t even be sure I hadn’t missed something.

    I reran upgrade.php. I have now the ‘active_plugins’ row, with the plugins listed.
    “Hello Dolly” now works, so the basic mechanism is working, but “Adhesive” still does not work: there is no ‘sticky’ checkbox in the Post Status area. (I tried both 1.5 and 1.6alpha.)
    I haven’t tried the others, since they require changes to the basic code.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugins wont activate? (but say they do)’ is closed to new replies.