Support » Installing WordPress » plugins still using php4 after php5 turned on

  • Resolved spotcream


    Plugins dont recognise that php5 is now installed they still say php version 4.

    Plugin is w3 total cache amongst many others.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I would think if your host environment is using PHP5 then your whole WordPress installation would use PHP5

    Use the script at Finding_Server_Info to see what it says about the PHP version in use.

    Also might be worth at chat with your hosting company.

    I enabled php5 through cpanel and got the error no input file specified so seaarched on google and try several solutions i pasted the below into my .htaccess file with php5 enabled and the site showed up.

    <FilesMatch “\.(php|inc|phtml)$”>
    AddHandler application/x-httpd-php .inc .php .phtml
    AddHandler application/x-httpd-php-source .php5

    when i tried the php test it read php4 was in use so i removed the above from .htaccess file and again i got the error but now its saying php5 is running. STILL NO SITE

    hope you can help because this problem is doing my head in been like this for days lol

    You should call your host company.

    i did they got php5 working for me but i cant access my admin they said it is probably something to do with .htaccess but they are not sure i would have to speak to some one who knows more

    Do you receive an error of some sort when you try to access the login URL? An error message would definitely help in figuring out what the problem is and offering a possible solution.

    well it lets me enter my username and password then instead of going to admin it just displays no input file specified.

    Could this be a .htaccess problem

    AddHandler application/x-httpd-php5 .php

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    AuthUserFile /home/private/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/private/public_html/_vti_pvt/service.grp

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


    # END WordPress

    This is not a WordPress issue.. but..

    What happens if you save this file


    As mytest.php ? Then browse to it?

    What if you save it as mytest.php5 ?

    it displays php info stating php5 is in use version 5.2.10

    i can view the site i just cant get into the admin area.

    If any one wants to try and set this up for me id welcome it.

    as .php5 it works displaying the same.

    PROBLEM IS SOLVED —- Solution was found by hosting company upon searching through wp forums alot of people have had the same if not similar problems.

    So most people are following correctly by putting a php.ini file in there folder but if you have admin problems insert another php.ini file into the admin section..

    Hope this helps you as it did me..

    Hey Spotcream,

    I’m not much of a coder, so I was wondering what the precise steps were that you followed to solve this issue. I’m pretty sure a problem I’m having with activating the Facebook Connect plugin has to do with not recognizing PHP5 after I had upgraded PHP5 🙁
    Well, any help would be appreciated. I’d contact my host, but they’re of the mind to not help in any way with anything related to 3rd party apps.
    Thanks for your time and consideration.


    Hi i would try placing a blank file use notepad and save as php.ini then upload to the directorys required.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘plugins still using php4 after php5 turned on’ is closed to new replies.