WordPress.org

Forums

[resolved] Plugins Still Showing Despite User Role Is Author (3 posts)

  1. saphod
    Member
    Posted 6 years ago #

    I wanted to set up an author account on my blog for someone else. Testing this account, I could see that some plugins are still showing up in the dashboard menu:

    FeedStats:
    http://bueltge.de/wp-feedstats-de-plugin/171/

    WP-ServerInfo & WP-Useronline:
    http://lesterchan.net/portfolio/programming/php/

    WordPress Reports (for Google Analytics):
    http://tantannoodles.com/toolkit/wordpress-reports/

    Also, the "Settings" menu is shown with the ability to configure the plugin "Search Phrases" ( http://gluehwein.junkies.ws/2006/10/16/plugin-search-phrases-anzeige-der-letzten-suchbegriffe/ ).

    Why is that?
    Shouldn't they all be invisible for the author role?
    How can I fix that?

    BTW:
    I just installed Akismet 2.2 which is causing some trouble.
    Could that be the culprit?

  2. saphod
    Member
    Posted 6 years ago #

    Akismet was updated to 2.2.1 and seems to work fine now.

    Still, the above plugins are shown as author.

    Any help would be nice.

    [Update]
    At least, FeedStats-de has a settings option which user levels shall be able to see the menu. Changed it.

  3. saphod
    Member
    Posted 6 years ago #

    OK, it was all about the user level in "add_submenu_page" and "add_options_page". I set it higher than author - and now everything is fine.

Topic Closed

This topic has been closed to new replies.

About this Topic