Support » Fixing WordPress » Plugins say they update, but they aren't showing as updated

  • We are having the same problem, the plugins show that there is an update available, we click to update, the process happens and it says that they have updated successfully, but when we go back to the plugins page they still say there is an update available.

    When we look at the plugin folders via FTP they show the date we updated the plugin and the files have actually been updated. Something isn’t connecting with WordPress somewhere. Any idea what can be done?

    We’ve done a manual WordPress upgrade and that didn’t fix anything.

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. then re-activating the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin and again re-activating the plugins one by one until you find the problematic plugin(s). Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Do you have a caching plugin installed? You might just need to clear your cache.

    Hi esmi – thank you for your pointers. We’ve tried all of these to no avail. From what we can tell, the updates are taking place, but they just aren’t being reflected on the plugins page in admin. Activating and deactivating the plugins are reflected on the site (like activating wptouch and deactivating it).

    It’s just really confusing and we can’t figure out if it’s a WordPress issue or a hosting issue or a database issue.

    Any idea where that page get’s the update status from or where to check if it’s looking in the correct place?

    Any other ideas are welcome!



    Forum Moderator

    I agree with Doodlebee that this sounds like a caching issue ( although I’ve never heard of a caching plugin affecting the admin area of a site). Have you tried using another browser? Another computer on a completely different network?

    I’ve had W3TC do it to me before, when I accidentally set the admin to cache :). You know, ’cause I was good like that. I’ve also had Firefox do it to me quite often, which is why I swapped to using Chrome.

    That’s another thing you can try – open the admin in a different browser. See if it’s still doing it.

    I’m using Chrome and we did have W3TC installed, but deactivated it because of other issues. I’ll try deleting those remaining files and see what happens.

    Okay, I’ve tried everything that everyone had suggested to no avail. I did discover that there was a dev site along with a dev db that still lives on one of the servers. Is there a chance that the live version of the site is still somehow communicating through a setting in the db that wasn’t changed and getting the plugin update notifications from the dev site?

    I’m not sure if that’s possible or not, but I’m looking for any solution I can find. I’ve installed the site locally using the live DB and live files, but it works fine.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugins say they update, but they aren't showing as updated’ is closed to new replies.