WordPress.org

Support

Support » Localhost Installs » Plugins not showing up after Fedora 20 automatic installation on local server

Plugins not showing up after Fedora 20 automatic installation on local server

  • Hello.

    I installed WordPress through the RPM package of Fedora 20, on a local PC. It worked, except that there were no “Add new” button either in “Plugins” or in “Appearance→Themes”, because /usr/share/wordpress/wp-config.php included the 2 lines:

    /* Disable all file change, as RPM base installation are read-only */
    define('DISALLOW_FILE_MODS', true);

    I reported a bug to Fedora bugzilla and replaced “true” by “false”. Then I got the “Add new” buttons, but my computer is not configured to be a FTP server (which seems a bit complicated to do) and, whatever plugin I put in /usr/share/wordpress/wp-content/plugins , it doesn’t appear in the plugins list page
    http://localhost/wordpress/wp-admin/plugins.php

    I checked the plugin folders were not nested.
    In wp-config.php, line define('AUTOMATIC_UPDATER_DISABLED', true);, I tried replacing “true” by “false”, which did no good.
    I changed the owner and rights:

    # chown -R apache:apache /etc/wordpress/
    # cd /usr/share/wordpress/
    # chown -R apache:apache .
    # find . -type f -exec chmod 644 {} \;
    # find . -type d -exec chmod 755 {} \;

    not to avail…

    I have the same problem with themes, except that, when I want to install a theme already installed, I’m only proposed to update it, not to install it, and, if I choose to do so, am answered it is already up to date.

    Do you have any idea to get installed plugins and templates show up?

  • The topic ‘Plugins not showing up after Fedora 20 automatic installation on local server’ is closed to new replies.