Support » Networking WordPress » Plugins Not Loaded for on Network Sites page

  • Resolved Rick Hellewell

    (@rhellewellgmailcom)


    The Network Admin page has a Sites entry; that page shows all network sites (blogs), and you can edit a Site. That Site edit page has tabs for various functions.

    I created a plugin that adds an additional tab with additional settings. I need to display one of the additional settings on the Site list page. This is done via the manage_sites-network_columns filter that adds to $sites_columns.

    But the Network, Sites page (network/sites.php) does not load plugins. Which means that the manage_sites-network_columns filter in my plugin is not executed.

    The only way to get the manage_sites-network_columns filter active on the Network, Sites screen is to add that filter to the theme. Which negates using the plugin to add a column on the Network, Sites page.

    The plugin has been network activated, and the plugin functions to add to the Network, Site Edit screen work – that page apparently loads plugins.

    How to best get plugins loaded on the Network, Sites page so my plugin features will work on that page?

Viewing 2 replies - 1 through 2 (of 2 total)
  • But the Network, Sites page (network/sites.php) does not load plugins.

    This is not true. The network/sites.php absolutely loads all network activated plugins. You can try posting more of your code and maybe someone can help identify the problem. And/or try installing Query Monitor for additional debugging information.

    Thread Starter Rick Hellewell

    (@rhellewellgmailcom)

    You are correct, of course. Found the error in my code, which was hiding from the error logs for some reason.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugins Not Loaded for on Network Sites page’ is closed to new replies.