WordPress.org

Forums

Plugins not displaying... (12 posts)

  1. scrumpy-uk
    Member
    Posted 9 years ago #

    Been using WP 1.5 for a while now quite happily however I've just stumbled upon a problem trying to get the WPG2 plugin to work.

    I've placed the directory in the right folder but it doesn't show up so I can activate it. I've also added the backup plugin directly into the folder with the other plugins and I get the same thing, nothing showing up.

    Any ideas.

    Thanks,

    Stuart

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Do any plugins at all display ?

  3. Class
    Member
    Posted 9 years ago #

    Maybe the permissions are wrong?

  4. scrumpy-uk
    Member
    Posted 9 years ago #

    The plugins that come with WP are deactivated and I can see them in my plugins page. The permissions of the new plugins I've created in the directory are the same as the ones that show up in the plugins page.

  5. Cypher
    Member
    Posted 9 years ago #

    Open the plugin file and look for something like:


    /*
    Plugin Name: Hello Dolly
    Plugin URI: http://wordpress.org/#
    Description: This is not just a plugin, it symbolizes the hope and enthusiasm of an entire generation summed up in two words sung most famously by Louis Armstrong: Hello, Dolly. When activated you will randomly see a lyric from <cite>Hello, Dolly</cite> in the upper right of your admin screen on every page.
    Author: Matt Mullenweg
    Version: 1.5
    Author URI: http://photomatt.net/
    */

    There should be something similar at the top of the file, WP uses this to list the relevant information on the Plugins page.

    Regards

  6. YellowSwordfish
    Member
    Posted 9 years ago #

    Curiously, I am having the exact same problem with the 'titleimages2' plugin. The header info in the file looks fine and all other plugins show up in the plugin panel - but not this one. I was hoping to have a play with it as the 'Headline Images' plugin just wont work for me.

    ANy other ideas anyone?

  7. scrumpy-uk
    Member
    Posted 9 years ago #

    The plugin is valid:

    <?php
    /*
    Plugin Name: Gallery2 Integration
    Plugin URI: http://wpg2.ozgreg.com/
    Description: Integrates WordPress users, theme and single sign to Gallery2.<br/> Documentation, Support Forums.
    Author: Ozgreg with CSS design by Marc Lorenz
    Version: RC1
    Author URI: http://www.ozgreg.com/
    Updated: 8/10/05

    Past code, invaluable design & help, thanks to John Arnold

    This program is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; either version 2 of the License, or
    (at your option) any later version.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
    GNU General Public License for more details.
    */

    It just doesn't show up. I've upgrdaed to the latest WP, although it only shows 1.5 in the dashboard; I'm assuming this is OK?

    Stu

  8. scrumpy-uk
    Member
    Posted 9 years ago #

    Stranger still, I've deleted the hello.php plugin and it's still visible in the plugin UI; I can also still activate and de-activate it.

    I'me getting the feeling that this is a bug or a problem with the upgrade to the latest WP; of which I follows the instructions to the letter.

    It's not browser cache or anything like that.

    Stu

  9. YellowSwordfish
    Member
    Posted 9 years ago #

    Found out what was stopping 'titleimages2' plugin from showing. Didn't have adequate read permissions on the php file, so I guess it got scrambled on the download. You might want to check your permissions on your plugin to make sure.

  10. scrumpy-uk
    Member
    Posted 9 years ago #

    What permissions did you have, I have 644 on all the plugin files in the plugins directory.

  11. YellowSwordfish
    Member
    Posted 9 years ago #

    644 should do the trick. For some reason when I loaded mine up it had lost some of the permissions. So - not the same problem then. Sorry....

  12. jfalcon
    Member
    Posted 9 years ago #

    Same deal with me. Except for the default 3, I get nothing. I've verified everything in the thread.

    Using: IIS6/PHP4/MySql

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags