[resolved] Plugins installation and FTP information (5 posts)

  1. zubair04
    Posted 3 years ago #


    I've recently just installed wordpress on a dedicated server and have the dashboard up and running.

    However, whenever i continue to install plugins (in particular WP Super Cache plugin) it keeps asking for my FTP credentials

    I've provided the same credentials i use when i log into Cute FTP (this is how i installed the wordpress files), however, wordpress repeatedly tells me "FTP hostname is required"

    I have tried every variation of hostnames known to man , but still seem to get this error

    (my ip address)

    I have also hardcoded my details in Wp-config to no avail

    define('FTP_USER', 'usernamr');
    define('FTP_PASS', 'password');
    define('FTP_HOST', 'ftp.messr.co.uk.');
    define('FTP_SSL', false);

    I have also reinstalled wordpress, and continue to get teh same errors. I can confirm my username and password are correct as i can access ftp when entering http://ftp.messr.co.uk in my address bar

  2. Chris
    Posted 3 years ago #

    Two cases come to mind:
    1. Check the folder permissions
    2. Check if PHP is running in the proper context


  3. zubair04
    Posted 3 years ago #

    I think i will call the server provider with regards to folder permissions.

    It's currently running on a windows server, with IIS i presume, do you know what permissions need to be applied to which folders ?

    If that fails, what do I need to do in order to check if PHP is running correctly ?

    Thanks for your help so far

  4. Chris
    Posted 3 years ago #

    Sorry but I don't know enough about windows servers since I'm using linux for my web hosting. So maybe someone else could chip in some infos about that?

  5. zubair04
    Posted 3 years ago #

    Hi Chris,

    Thanks for your help. Turns out this was a permissions issue which has now been solved.

    Onto the next problem of the ridiculous load time for the site itself.

    I'll mark this as solved, and can confirm it was a permissions issue on the IUSR account for IIS 7

Topic Closed

This topic has been closed to new replies.

About this Topic