Plugins don't work. Any of them. (3 posts)

  1. TheUnlike
    Posted 2 years ago #

    I manualy upgrade wordpress to 3.5 version. Everything was fine, but then I try to active again my plugins and they don't want work. Non of them. Even when I want uninstall them there is a mistake. It show:

    Warning: Missing argument 2 for wpdb::prepare(), called in /homepages/44/d409215179/htdocs/wordpress/wp-content/plugins/category-icons/category_icons.php on line 1047 and defined in /homepages/44/d409215179/htdocs/wordpress/wp-includes/wp-db.php on line 990

    What can I do with this? I really need this plugins to run.
    I try to reinstal them but it doesn't help.

  2. jibbius
    Posted 2 years ago #

    This is an issue that will need to be fixed by the plugin developer.

    For now, if you edit this file:

    Look for the following on line 1047:

    prepare(Some code...)

    Replace it with:

    prepare(Some code... ,"")

    If you don't have FTP access to the site, I would not do this, or be extremely careful. If you make a mistake you may be unable to access the site to fix it.

    EDIT -
    Ignore the advice above, you would be better just to contact your plugin dev.
    You can turn off the warning messages, by following instructions here:

  3. jibbius
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.