Support » Plugin: WooCommerce » plugins arent working

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,
    Need more info to see if we can help. Has the shop and various plugins ever worked? If so, what was the last action done prior to the loss of function?

    Heres the site
    The USPS shipping plug in worked for several months. Now its not working again and hasnt since even before WP 3.6
    Also there is an update for PayPal Pro that sometimes shows in my “installed plugins” area of the dashboard and other times it doesnt.
    The USPS plugin is showing shipping prices even before they input a zip code or before they click the calculate shipping buttton. The shipping prices its showing are wrong also, which is odd since this info is supposed to come from the USPS API
    Any help would be apprteciated

    Hmmmm… a live site with issues presents a whole different problem.

    The standard debug method would be to turn off all plugins except woo, usps and paypal pro, and switch to the 2012 theme, and retest. If successful, then roll in all the plugins/theme one by one until the issue is found.

    Assuming that either you’re not willing to do this in a production site, or the problem turns out to be WOO-related, a different approach would be called for.

    Create a fresh, new wordpress test environment, using WP 3.6+ . Install your theme and the woo plugins, create some test data, redo the test from above.

    If that’s no help, recreate the WP environment anew, again. This time use an older version of WP (say 3.4 or 3.5) and older versions of woo, etc. Redo the data creation and tests. If good, roll 1 variable to current (start with WP itself) and retest. Rinse and repeat.

    Pain the hind quarters, but comprehensive…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘plugins arent working’ is closed to new replies.