Support » Plugins » Plugin.php (Plugin Admin Page) Won’t Load

  • I’m installing WordPress on a new server and everything goes smoothly, but once it’s installed I try to click on the plugins page and it just sits there trying to load, but nothing loads on that page.

    I finally deleted all the plugins that were in wp-content/plugins and the page loads fine. However, as soon as I add a plugin in that folder (any plugin) then the plugins page can no longer load.

    I thought maybe it was a permission issue and so I’ve tried a whole variety of permissions, making the web server user the owner of that folder. 644 for all files. 755 for all folders. I looked through the wp_options table to see if maybe there was a location hard coded that it was looking to find the plugins folder and everything was correct.

    We did move the WordPress folder and changed the virtual host in Apache to go to the new location. So, since we moved it, I tried installing a blog from scratch to see if a clean install of WordPress would have the same problem and it does.

    Anyone have ideas on what I could check/do to get this working? I assume it must have something to do with some combination of permissions/owner/location that wp-admin/plugins.php is trying to use to access the plugins folder since it will load when no plugins are in that folder.


Viewing 6 replies - 1 through 6 (of 6 total)
  • I have a similar issue: when I try to activate certain plugin combinations, I get http 500 errors on the admin page.

    That’s interesting. My page won’t even load with no plugins activated at all. They can all be in there inactive and the page won’t load. With no plugins in the plugins folder, the page loads fine. Seems like it’s trying to find the plugin folder to be able to list the available plugins and can’t find it or something. That’s why I think the key is figuring out how WordPress finds out the list of plugins available in the plugins folder.

    Has anyone posted a solution to this??

    Running 2.7 and the same thing happened to me. Plugin admin page wouldn’t load unless there were no plugins in the plugin folder. Even hello.php was enough to trigger it.

    Safari would instead display a ‘server dropped connection’ message. Firefox loaded a blank page. And yet a duplicate version of the site running on my Mac loaded fine.

    In my case too, the hosting company had migrated the site to a new server, which had a different absolute path “/var/www/<domain>/httpdocs” – previously it had been “/web/guide/<username>/public-html”.

    I installed a vanilla WP in a subdirectory on the same site and it worked fine with a duplicate set of plugins.

    So I bit the bullet and updated to 2.8.4, hoping that the database upgrade would clean out whatever was screwing the site.

    It worked. 🙂

    This seems to have fixed everything for me!

    Add this to your htaccess if your host has php4:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    I ran across the solution while messing with a plugin that requires php5 and I noticed that my website is hosted with php4.

    Just set this up a few minutes ago, but everything seems to be running smoothly now. I can enable as many plugins as I want, too. Will report back if I run into any problems down the road.

    So nice to have it working properly again. Can’t believe I struggled through that for 3 months! FYI, PHP 4.4.9 is what my host currently uses. Should be fine according to wp requirements, but certain plugins probably prefer php5.

    Hmmm that didn’t work for me. I am having the same issue — when I add the above code, something does display now when I go to the plugins.php page, but it’s a bunch of code that displays

    $time) { if ( isset($recent[ $plugin ]) ) unset($recent[ $plugin ]); } if( $recent != get_option('recently_activated') ) //If array changed, update it. update_option('recently_activated', $recent); wp_redirect('plugins.php?activate-multi=true'); exit; break; case 'error_scrape': check_admin_referer('plugin-activation-error_' . $plugin); $valid = validate_plugin($plugin); if ( is_wp_error($valid) ) wp_die($valid); error_reporting( E_ALL ^ E_NOTICE ); @ini_set('display_errors', true); //Ensure that Fatal errors are displayed. include(WP_PLUGIN_DIR . '/' . $plugin); do_action('activate_' . $plugin); exit; break; case 'deactivate': check_admin_referer('deactivate-plugin_' . $plugin); deactivate_plugins($plugin); update_option('recently_activated', array($plugin => time()) + (array)get_option('recently_activated')); wp_redirect('plugins.php?deactivate=true'); exit; break; case 'deactivate-selected': check_admin_referer('bulk-manage-plugins'); deactivate_plugins($_POST['checked']); $deactivated = array(); foreach ( (array)$_POST['checked'] as $plugin ) $deactivated[ $plugin ] = time(); update_option('recently_activated', $deactivated + (array)get_option('recently_activated')); wp_redirect('plugins.php?deactivate-multi=true'); exit; break; case 'delete-selected': if ( ! current_user_can('delete_plugins') ) wp_die(__('You do not have sufficient permissions to delete plugins for this blog.')); check_admin_referer('bulk-manage-plugins'); $plugins = $_REQUEST['checked']; //$_POST = from the plugin form; $_GET = from the FTP details screen. include(ABSPATH . 'wp-admin/update.php'); $title = __('Delete Plugin'); $parent_file = 'plugins.php'; if ( ! isset($_REQUEST['verify-delete']) ) { wp_enqueue_script('jquery'); require_once('admin-header.php'); ?>
          ', sprintf(__('%s by %s'), $plugin['Name'], $plugin['Author']), ''; ?>
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin.php (Plugin Admin Page) Won’t Load’ is closed to new replies.