[Plugin:NextGEN Gallery] Select part of the photo for thumbnail (17 posts)

  1. petrawp
    Posted 6 years ago #

    In the former version of the plugin NextGen Gallery it was possible to select a part of the photo, that must be showed as the thumbnail. In this new version 1.4.3 I can rotate pictures, but I do not find the possibility anymore to select the part of the photo that should be the thumbnail. Or am I mistaken?


  2. rughooking
    Posted 6 years ago #

    Go to Manage Galleries. As you scroll over one of your images in the gallery some menus items show up:
    View | Meta| Edit Thumb | Rotate | Delete
    Choose Edit Thumb. A pop up window will open. Drag and drop to create a square on the full image. You can then adjust the size and move it around as needed.

  3. erikacw
    Posted 6 years ago #

    Hi, I tried to do this but doesn't work... I am using wp 2.8.6 ans nextgen-gallery 1.4.3
    The popup window is opened but the full image doesn't appear in left side. Any idea?

  4. danatang
    Posted 6 years ago #

    I have the same problem:the full image doesn't appear in left side.
    Anyone can help?

  5. Alex Rabe
    Posted 6 years ago #

    I've disabled this feature on IE browser (there are a lot of bug inside, which I can't find), it should be working on FF or other browser...

  6. greenchillidesign
    Posted 6 years ago #

    Hi, I can confirm this isn't actually working in 'FF3' or 'Safari 4' on the Mac.
    Please see screen shot:

  7. Thumbslapper
    Posted 6 years ago #

    I get the exact same as greenchillidesign. Doesn't work in FF, Chrome or Safari for mac on WP 2.9.
    The weird thing is that I remember actually having this cropping-ability in an earlier install. Where did it go, I wonder?

  8. exposia
    Posted 6 years ago #

    Has anyone got a fix yet??? I also get exactly the same on FF3, Safari 4 on mac. see capture.
    The crop feature was working when i initially installed, however, after rebuilding a couple of galleries with different dimension thumbs, it stopped working. This is a Major issue as there are a LOT of wedding images on this site and i cannot get it to work at all! please help :)

  9. Alex Rabe
    Posted 6 years ago #

    Mhhh I need a Mac to work on this, donation are welcome :-) Sorry , If I found a solution I will of course release it, Safari in Win7 works fine so far

  10. exposia
    Posted 6 years ago #

    Hi Alex, thanks for getting back to me. I am not sure this is is a css/browser issue as i get the same on xp with FF. And also, the image url output on the left is "nggshow.php.jpeg" whereas the output URL passed to nggshow.php is "http://blog.greenphotographic.caliban.titaninternet.co.uk/wp-content/plugins/nextgen-gallery/nggshow.php?pid=459&width=350&height=350"

    It was all fine until i tried creating some custom sized thumbnails. Thanks!

  11. Eduard Seifert
    Posted 6 years ago #

    You need to save the functions.php in UTF-8 without BOM (Dos\Windows ANSI as UTF-8). Worked for me using Notepad++. Had the same problem with cropping thumbs.

  12. mike58
    Posted 6 years ago #

    did set convert to UTF-8 without BOM in Notepad++
    saved as php...
    then the whole nextgen disappeared from the menu...



  13. ectorg
    Posted 6 years ago #

    Geez people, I think I've figured out the solution!!!

    Same problem as above, everything just went haywire and I was getting all of these Cannot Modify Header messages. It was always in the nggallery.php file. I'd deactivate plugins, tons of error messages, just a big fat mess. Then I'd think I would get it fixed, get rid of the error messages and then the problem of no left image, per exposia's screen shot. I'm on Mac and Firefox 3.6.3, btw.

    What fixed it (reading lots of threads here and kind of putting everything together):

    1. Go to the nggallery.php file in the nextgen plugin folder.
    2. Open that with whatever you use to edit files (I use page spinner) that doesn't add a bunch of crap. I guess Notepad in Windows.
    3. Go to the bottom of the file and the end is:
    4. Use your arrow keys to see if there are blank spaces beyond that, if so, use backspace and get rid of them.

    Now this part is weird, but I ran into it here, regarding a messed up config file (and it's in the WordPress help files)

    5. Put your cursor between the question mark and whatever that other thing is called. I'll use a dollar sign to mark where cursor should be:

    6. Press your DELETE button, not the backspace, but find DELETE. It's going to delete that pointy thing. Hold it FIFTEEN seconds. Then type the pointy thing:

    Sorry, don't know what that's called.

    Then save your file (I save directly back to my FTP, but do it however you do it)

    Apparently somehow a space is being put in between those two characters and is mucks it all up. I did this and like magic, I can now edit thumbs again, and all those horrible error messages are gone.

    This sounds a LOT more complicated than it is. Once you get to the file and do the delete thing, it's quick and painless.

    Hope this helps somebody...I've been tearing my hair out all afternoon.

  14. ectorg
    Posted 6 years ago #

    Here is the WordPress help file on this, just follow it and do it on the nggallery.php file instead of your config file.


  15. Coobakai
    Posted 6 years ago #

    Any other fixes for this? I've tried all the advice above, and no luck so far. The thumbnail editor is not working in any of my browsers—FF3.6, Safari 5, or Chrome 5.

  16. thedrewseum
    Posted 6 years ago #

    Sorry ectorg, that didn't fix the problem for me, still can't use the thumbnail editor :(

  17. indigi
    Posted 5 years ago #

    The nggallery.php file, as released by Alex, does not have the issue that ectorg suggests.

    This is a server memory issue, not a browser issue. See


    for more information.

    Comment by @Newport shows a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.