WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Zotpress] Warning: DOMDocument::loadXML() [domdocument.loadxml]

[Resolved] [Plugin: Zotpress] Warning: DOMDocument::loadXML() [domdocument.loadxml]

Viewing 15 replies - 1 through 15 (of 15 total)
  • FHeimburger
    Member

    @fheimburger

    Same here “Warning: DOMDocument::loadXML() [domdocument.loadxml]: Start tag expected, ‘<‘ not found in Entity, line: 1 in /home/franziska/franziska.fr/htdocs/openscholar/wordpress/wp-content/plugins/zotpress/zotpress.admin.default.php on line 257”

    This is on a self-hosted server, so if there is something that needs adjusted on the php-side etc. I can do that, I just need to know what/where.

    FHeimburger
    Member

    @fheimburger

    odder still – it works fine with my personal library, but fails on the public group library I am trying to set up with ZotPress.
    Any ideas, anyone?

    same Problem as FHeimburger here.
    Connecting to personal library of account without problems, connecting to the group library hosted at same account produces the error cited above.

    Help appreciated 🙂

    Plugin Author Katie
    Participant

    @kseaborn

    So, this error occurs just for group libraries? Will look into this …

    flammobammo
    Member

    @flammobammo

    It’s also occurring for me, using a user (not a group) library. It was working fine when I was using the TwentyTen child theme of bbPress, but then I changed to using a TwentyEleven child theme for bbpress, and then it started to give me this error.

    If I delete [zotpress limit="99" sortby="date"] and replace with just [zotpress] then it works fine again though.

    On another matter, should the inclusion of datatype="report"lead to only displaying reports? Because this doesn’t seem to be working either. 🙁

    Plugin Author Katie
    Participant

    @kseaborn

    I can’t seem to replicate this error in WordPress 3.2.1 with the TwentyEleven theme. However, I’m just about to release a new version of Zotpress, in which I fixed a couple of bugs — they could be related to this problem. Please check out the new version and report back if you’re still seeing this error.

    FHeimburger
    Member

    @fheimburger

    Yay – thanks so much, it works beautifully with the group library now.
    Thank you so much for your brilliant work !

    Plugin Author Katie
    Participant

    @kseaborn

    Awesome!

    jgieseking
    Member

    @jgieseking

    I’m having this issue now. I just made a group library and tried to upload and got that error.

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: Start tag expected, ‘<‘ not found in Entity, line: 1 in /home/spatially/www/www/gendergeog/wp-content/plugins/zotpress/zotpress.admin.default.php on line 257

    Any thoughts?

    jgieseking
    Member

    @jgieseking

    I deleted my group and re-entered my API and User ID and reattached the group. It worked perfectly.

    I too am having the same problem. zotpress recognizes my user library but not my group library. This is a major problem since the site I’m working with is an organizational website. Not good. I tried to do what jgieseking did, but the explanation was a bit vague. It would be nice to get a little more of a walkthrough of how jgieseking accomplished the task.

    Plugin Author Katie
    Participant

    @kseaborn

    I’m not sure what jgieseking was referring to, but you could try deleting the synced group account in Zotpress, then adding it again. You could also try deleting the entire cache using the button on the main Zotpress page.

    jgieseking
    Member

    @jgieseking

    This was user error. I made a group list, then I tried to add it to zotpress with a userid & private key but it would just give me those errors. When I added the groupid # (found in the web address on the zotero page), I just added the groupid and private key and it worked.

    Cheers.

    La M
    Member

    @lady_moocher

    You are probably trying to create a Zotpress “Group” Account rather than a “User” Account. So you need to use the Zotero GROUP ID and not User ID.

    You can find your Zotero Group ID by making your group private and viewing its url.

    For full steps, see http://wordpress.org/support/topic/plugin-zotpress-change-field-description-on-add-account-page?replies=1

    Hi. For solve the problem to run Zotpress on LOCALHOST, edit “php.ini“. Localize and edit this lines as follows:

    1. display_errors = Off
    2. error_reporting = E_ALL & ~E_NOTICE
    3. extension=php_curl.dll

    This enables the apache for cURL functions, used for the Zotpress plug-in (and Advanced Bibliplug to), and works fine.

    Congratulation for the great bibliographical plug-in.

    ref. error mensage: “Warning: DOMDocument::loadXML() [domdocument.loadxml] etc…”

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Plugin: Zotpress] Warning: DOMDocument::loadXML() [domdocument.loadxml]’ is closed to new replies.