[resolved] Shortcode error (2 posts)

  1. iamarogue
    Posted 4 years ago #

    I'm getting an error that I can't figure out. Unfortunately, I can't really tell you what I did to cause the error, other than zotpress was working fine and now it is not.

    On one of my pages, I have the following short code:

    [zotpress collection="RAEV8B4B" sortby="author" limit="99"]

    But when I view the page, I get these errors at the top:

    Warning: asort() expects parameter 1 to be array, null given in /home/aryder/involvingthepublic.com/wp-content/plugins/zotpress/zotpress.shortcode.functions.php on line 43
    Warning: Invalid argument supplied for foreach() in /home/aryder/involvingthepublic.com/wp-content/plugins/zotpress/zotpress.shortcode.functions.php on line 46
    Warning: Invalid argument supplied for foreach() in /home/aryder/involvingthepublic.com/wp-content/plugins/zotpress/zotpress.shortcode.php on line 431

    And on the page where it should output the bibliography, I get:

    Sorry, but Zotpress encountered an error after attempting to contact the Zotero server. (Try again?)

    On the Zotpress admin page, it shows my latest citations, then I selected a collection and it gave me the following error:

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: Start tag expected, '<' not found in Entity, line: 1 in /home/aryder/involvingthepublic.com/wp-content/plugins/zotpress/zotpress.admin.default.php on line 257

    I tried to recache the page, and now it gives me that error permanently.

    So why is this happening? As I mentioned before, I unfortunately don't know what I did. I recently updated to 3.3.2 but that could have been before or after Zotpress stopped working. I think I did put in a shortcode on a page using a placeholder of collection="XXX" because I was just copying and pasting from a different page. The only other plugin I have installed is WP UI, and I'm using DreamHost, so I don't think it's the server.

    Any help?


  2. Katie
    Plugin Author

    Posted 3 years ago #

    I believe this should be fixed in 5.0. Please let me know if it's still not working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic