Support » Plugins and Hacks » [Resolved] [Plugin: Zotpress] Default bibliography style not getting displayed

[Resolved] [Plugin: Zotpress] Default bibliography style not getting displayed

  • Hi!

    I set my default style to “chicago-fullnote-bibliography”, both on the Options tab of Zotpress and in the page of my site where I’m displaying the bibliography (option 6 of the Shortcode Creator). Still, this style doesn’t get displayed unless I manually add it to the shortcode. Eg: [zotpress collection=”D9J52JXR” style=chicago-fullnote-bibliography].

    This cannot be intentional. Can you confirm this is not the expected behaviour (and that there’s some bug here)?



Viewing 2 replies - 1 through 2 (of 2 total)
  • I have the same problem. Regardless of which default style I set (author, date) shows up using the InText shortcodes. I can’t seem to get the style to change even when I add the “style=” parameter.

    I’m also using the Zotpress widget, which does change styles when I specify a new style in the widget, but when I implement the “vancouver” style or any numbered biblio style, all the refs are numbered “1”. This also happens when I use the InTextbib shortcode. How do I get the refs numbered sequentially?

    Finally, since I can only get (author, date) using the InText shortcode, can I possibly change it to (author, YEAR) instead of (author, DATE)?

    Thanks for all your work on Zotpress! I have thousands of references organized in Zotero, but I’m new to WordPress. Zotpress will certainly be an invaluable tool, once I get the kinks worked out. Kudos to Katie!

    Plugin Author Katie


    The first style issue and year/date exchange should be fixed in 5.0! Please let me know if otherwise.

    @otaber I haven’t figured out a good fix for the numbers issue, but I am aware of it. Unless the bibliography is generated on the Zotero side, it will always return items with 1 instead of sequentially ordered. I’m pondering a solution and am open to suggestions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: Zotpress] Default bibliography style not getting displayed’ is closed to new replies.