WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Zenphoto Gallery] 2.0 plugin doesn't work with Zenphoto 1.4

[Plugin: Zenphoto Gallery] 2.0 plugin doesn't work with Zenphoto 1.4

  • Zenphoto Gallery 2.0 plugin does not seem to be working yet with Zenphoto 1.4 as I get this error message:

    Warning: Invalid argument supplied for foreach() in /home/user/public_html/wp-content/plugins/zenphoto-gallery/gallery.inc.php on line 52

    It is working flawlessly with Zenphoto 1.3.1.2 (the last version of 1.3 before 1.4 was released).

    Hopefully the plugin gets updated soon 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • Wow, ok, ZP 1.4 seems to change some things significantly. I will have to do the following things

    * Install ZP 1.4
    * Check wether 1.4 and 1.3 can be accessed in a compatible way
    — If so, implement that
    — If not, make Zenphoto Gallery handle both (by setting?)

    Right now, I do not quite have the time for that, sorry. If you can provide a temporary workaround (i.e. a json.php that offers the same as the one I built but works with 1.4) I would be happy to include it.

    I will fix it eventually, but only when I have a day or two to spare for it.

    By the way, do zenimage and zengallery work?

    In the ZP 1.4 release notes, it says that with mod_rewrite and the new .htaccess, old RSS links should work. Can you check that you have that set up?

    When does this exception/warning occurr? When you use zenalbum or zenlatest? Everything else works?

    Yes, as far as I can tell mod_rewrite and .htaccess are set up correctly on this fresh installation of Zenphoto 1.4

    I have only tried zenalbum as that is the only feature I am really keen on at the moment 🙂

    Maybe you have to add a new rewrite rule for treating requests for json.php in the same manner as those for rss.php?

    Ok I would try that but I do need more guidance here 🙂

    I plan installing ZP 1.4 myself sometime over the next weeks. So long, if you posted the content of the .htaccess here, I might be able to figure something out.

    Same problem here. 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Zenphoto Gallery] 2.0 plugin doesn't work with Zenphoto 1.4’ is closed to new replies.
Skip to toolbar