WordPress.org

Support

Support » Plugins and Hacks » [Plugin: youtube with style] Calling jquery messes with my other scripts

[Plugin: youtube with style] Calling jquery messes with my other scripts

  • As of v7.0 you call jquery from within the plugin. This messes up most of my other function calls. Please use wp_enqueue to load jquery and check if it hasn’t already been enqueued. Doesn’t make sense if every plugin loads the same library over and over again.

    I’ll revert to 5.0 until this has been fixed.

    http://wordpress.org/extend/plugins/youtube-with-style/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey that’s the same problem I have but I don’t have the 5.0 file… Do you know where abouts I could download the previous version?

    sorry about that, i changed it to use wp_enqueue, should work now, let me know if theirs any issues (give it 15 mins or so to update in the codex)

    brainsolid
    Member

    @brainsolid

    Another question — i use smoothgallery in my theme and previous versions of youtube with style don’t confront with it, but now smoothgallery not work.

    As i see, you use jquery for add a video via the post media manager — i can suffer this function for my gallery, so can you explain what lines in what file i can cut to fix this confrontation of scripts?

    i tested smoothgallery, it seems they have a bug, it has nothing to do with jquery, as I updated it to only use it via the admin.

    smoothgallery plugin seems not to work if its not the very 1st post, if its the 2nd post on your site, it doesnt add the required info to the header of your wordpress.

    So im waiting for the author to address this issue with 2.9.2

    I tried smoothgallery just by itself no other plugins, and it only works if the gallery is a post above all others.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: youtube with style] Calling jquery messes with my other scripts’ is closed to new replies.