The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

YOURLS: WordPress to Twitter
[resolved] Lots of duplicates! (3 posts)

  1. msebald
    Posted 4 years ago #

    Hello all,

    I installed YOURLS and the WP plugin today. Everything is working fine exept that the WP plugin is creating short urls for articles accessed through the webserver over and over again - means that it creates lots and lots of duplicates in both wp_postmeta of WP database and also the YOURLS database.

    I tried both internal and external method. Both WP and YOURLS are on the same server in different vhosts. Both methods show the same effect.

    Interesting is that the option for unique long/short urls is turned on. But either the WP plugin and/or YOURLS is not caring about that.

    Unfortunally the WP plugin is unusable with this issue.

    I'm running 1.5.1 of the plugin, 1.5 of YOURLS.

    Any idea, anybody? Thank you a lot in advance. :-)



  2. msebald
    Posted 4 years ago #


    I also have this problem with duplicate short urls when these get created for existing pages and articles as these urls are browsed to.

    I found out the following:

    The plugins first creates a "yourls_fetching" parameter in wp_postmeta table for the page/article. Then it creates one or more empty "yourls_shorturl" entries.

    After that it creates (mostly more than one) "yourls_shorturl" entries with content (the short url it got from YOURLS). This content sometimes is the same short url, sometimes another. So YOURLS does not seem to care about its own unique setting.

    This always happens in this order (I could see this by checking the id field of wp_postmeta).

    When looking a bit into the code the plugin checks for "yourls_shorturl" and content in it. It stumbles upon the first entry (with the lowest id) which is always empty.

    Why it creates an empty field first, I don't know. But I think that it continues to create new short urls whenever the page/article is browsed to.

    It happens here with the two methods (remote and local webserver).

    Ozh, can you imagine what is going wrong here?


  3. msebald
    Posted 4 years ago #

    Ok, I finally solved this issue.

    The problem is the Page cache of W3 Total Cache (W3TC). I turned this off and everything started working ok. I love this plugin, now as it works as it is supposed to be.

    So if someone else is having these problems... ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • YOURLS: WordPress to Twitter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic