Support » Plugin: yolink Search for WordPress » [Plugin: yolink Search for WordPress] I can't get an API key

  • Resolved GemmaW


    My host is WP Engine, and yolink is on their list of curated plugins, so it came pre-installed.

    I’m using Google Chrome (latest version).

    After activating the plugin, I went to the settings page and accepted the agreement. But I was redirected to the same page, as if I hadn’t accepted the agreement. There wasn’t any sign at all of anything to do with an API key. It seems to be a weird redirect loop.

    So, I tried deleting the plugin via the installed plugin list, and then reinstalling it via the plugin directory. I tried this a few times without any luck.

    Then I decided to deactivate all the other plugins to see if there was a conflict. That didn’t solve the issue.

    I’ve tried clearing the browser cache, and that hasn’t resolved things.

    I’ve checked the widgets and there isn’t any widget for yolink (I’m not sure if there’s meant to be one).

    I’ve looked on the yolink website and can’t find any helpful info.

    So any suggestions? I’m out of ideas.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author tigerlogic


    Hi, we apologize for the inconvenience. We performed a data migration with our API provider, and there have been some complications. We are diligently working on the issue and will let you know as soon as we are operational again.

    -yolink Search Team

    Plugin Author tigerlogic


    The accept agreement should be working now, we are still bubbling up issues from the data migration with our API provider, and we hope to resolve that by the end of the week. But you should be able to try it and crawl up to 50 docs at this point.


    Thanks. I have the API key now.

    But I’m at a loss as to what to do next.

    I don’t see any evidence of it replacing native search, and I certainly can’t see a yolink widget to use.

    I can’t use the registration wizard on your site because all that does is tells me to download, install and activate a widget, which apparently doesn’t exist. It doesn’t let me go on to the next step in the wizard.

    Plugin Author tigerlogic


    Hi GemmaW, if you would like to contact me directly., I will be more than happy to walk you through. We can setup a session or I can guide you via phone. Essentially, if you have accepted the agreement, yolink should be installed. You just need to add ‘search’ under the available widgets section to your site.

    It’s fine thanks. It appears to be working. I had to test it on a bare-bones theme to see that it was indeed installed and working though.

    That said, I may well have to get in touch later to signup for a paid plan, as that wasn’t working on your site before.

    Thanks for your assistance.

    Plugin Author tigerlogic


    GemmaW, if you don’t mind trying the signup for paid plans when you get the chance. Those purchasing issues should be resolved at this point. But if not, I’d be more than happy to handle the signup.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: yolink Search for WordPress] I can't get an API key’ is closed to new replies.