Support » Plugins and Hacks » [Plugin: Yet Another Related Posts Plugin] YARPP installed, but nothing shows up under the posts

[Plugin: Yet Another Related Posts Plugin] YARPP installed, but nothing shows up under the posts

  • I just installed YARPP 2.0.4 on scinico.org. the plugin is active. I have the manual setup with the code
    <?php echo related_posts(); ?>
    placed under the post content on my post php page.
    Yet nothing at all shows up, as if the plugin were not installed.
    I also tried the “automatically display related posts?” option in YARPP settings. Same result: nada, nothng.
    What am I doing wrong?
    thank you.

Viewing 15 replies - 1 through 15 (of 27 total)
  • @fscinio, hm, I apologize it doesn’t seem to be working out-of-the-box. Please check your preferences and make sure some of the key options are actually set and not blank (the “threshold,” maximum number of related posts, before and after the related posts display, the “no related posts” option, etc.). If for some reason those default settings were not set on install, it is possible that you will see absolutely no output.

    If those settings are indeed set but you see no output, please take a look at the source of your HTML files and see if there is any error code produced. Such strings would be valuable in helping me solve your problem.


    Same here.
    No dissalows
    Max posts 4
    Threshold 0.1
    Everthing ticked ‘considered’
    Automatically create reports is ticked
    Before and after entries populated

    If i enter a ‘default display’ then I see test on the post but otherwise, its blank.


    one more thing….
    No errors in the page source.

    I was able to get it working. I had to play wit the threshold level.
    thank you much.

    @stevepaine, by “default display”, do you mean the “no results display”? If that is being printed, than you indeed have no related posts for that post… I would recommend checking some other entries of yours, especially with such a low threshold.

    For all others: if you don’t see any results on install, try a lower threshold value first. Thanks!


    Hi mitchoyoshitaka

    By “default display” I mean “Default display if no results:”

    If I populate it, I get the test on the screen but if not, I get nothing.

    I have the threshhold at 0.1 and have tried 0.001 !!

    Still no results. My wordpress DB has 2500 articles in it on one product segment so i’m guessing there should be some good matches!


    @stevepaine I would love to work with you to try to solve this confounding issue… If you could email me with your skype or aim screen name perhaps we can get in touch and figure this out!

    Thank you for your time and comments,


    Hi mitchoyoshitaka,

    I have been having the same problem where no related posts show up as they they have in the past. In fact I remember seeing it a few days ago. I have tried the suggestions in this thread including taking the threshold level to .1.
    I don’t have any output on postings new and old. Can you help?


    I am using WP 2.6 should that make a difference.


    @markfu Please verify that the “no related posts” text is output… if you receive *no* output at all, that would be a vastly different problem. Please also check the source produced and see if there are any error messages produced where the related posts should be.

    If you always do get the “no related posts” text printed, just as with @stevepaine, I would love to work with you to resolve and patch the problem quickly. Please email me if that is the case. Thank you!


    Thanks micho. I am getting no output at all and no error message. I had seen “no related posts” in earlier posts, but nothing recently.

    Interestingly, when I go to the post as it appears to my readers, the is no output at all. When I go to the edit page of the post, and click on “View this post”, I get normal output. When I return to post again, still no output.

    @markfu Please check if that is a caching issue… do you use something like WP-Cache or SuperCache? If so, please try turning that off once (or reseting the cache) and see if that fixes the problem. If not, please let me know and I would love to try to work with you to solve the problem.


    Hello all. It seems I have the same problems. I’ve cheched all, used a very low treshold (0.1), deselected automatic display and used related_posts in my post page but i get “no related posts”.

    I also tried to check the existence of related_posts function and it exist and turned out caching plugins.

    My content is in Italian, don’t know if that can help.


    @thebigfox The Italian content should not be a problem… if you email me I can send you a debug version and we can try to figure out the issue.


    Hi all–

    With @thebigfox‘s help, I have identified an issue with my main query under MySQL 4.0 and below. (For those of you who are curious, my query uses a number of subselects, a feature introduced in 4.1.) I believe a workaround is possible, but… who still uses MySQL 4.0? Have some hosting services not upgraded? I’d love to get some feedback on this issue.

    If I do not work in the alternative query syntax into the plugin (which would be difficult as I would then have to maintain both query types), I will at least make sure to add a notice stating that the plugin requires >4.1. Thank you all for your reports!


Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] YARPP installed, but nothing shows up under the posts’ is closed to new replies.