Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] YARPP 3.2b error

  • When the post have no related posts, there is error:

    Warning: array_map() [function.array-map]: Argument #2 should be an array in /…/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 287

    Warning: join() [function.join]: Invalid arguments passed in /…/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 27

    Warning: Invalid argument supplied for foreach() in /…/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 54

Viewing 15 replies - 1 through 15 (of 17 total)
  • I am getting the same exact error for posts with no related entries. Posts that have related entries seem to be working.

    Lines 287, 27 and 54 on magic.php seem to be the issue.

    Not cool…

    I have the same issue. Fresh install of WP 3.0.1 and YARPP 3.2b. All my posts display this error message. I notice at the bottom of the page it says there are no related posts (which is not correct). But here’s where it get’s interesting.

    On a previous version of my site, (WP 3.0 and YARPP 3.19), I see no YARRP errors, and all my posts have related entries and work as they should. So I uninstalled YARPP 3.2b, and reinstalled YARPP 3.19 on WP 3.0.1). The errors messages went away, but all of my posts still say “no related posts”. Any ideas how I can get my posts to show up as related?

    Clearly YARPP 3.2b has some issues with the latest WP 3.0.1, and I suspect YARPP 3.19 does too (given my experience above – unless a residual sql table from 3.2b was an issue rolling back to 3.19).

    I do have the exact same problem and it seems to be all post that don’t have related content as mentioned by @ranji77 above. I deactivated the Plugin temporarily but hopefully we’ll see a solution to this soon.

    Sorry guys, I didn’t mean to push 3.2b1 as the new version. It’s a beta. I just changed the setting so it doesn’t push it out to people as a new stable version.

    Mitcho, any way to fix this in the short-term until a new official release of 3.2 comes out? I did what stormy did above and tried to roll back to YARPP 3.19. But now, every single one of my posts say “No related posts”

    Mitcho, can you temporarily fix this for 3.2b1? as if we downgrade to 3.19, it shall not work (as ranji77 said: all posts will have no related posts). the only way is disable 3.2b1 and wait for the stable one?

    If anyone have problem like this, all you need to do is, download to version 3.1.9, then deactivate the plugins, and activate again once you uploaded the files from 3.1.9.

    Then the problem with no related post will be solved and we can wait till the new version really stable.

    Hope this help.

    Going down to 3.1.9 should completely restore the state you were over time, although the cache will need to be rebuilt, so that will take time. You may see some “no related posts” in the mean time.

    As Eizil says, deactivating and reactivating YARPP will help.

    I just pushed 3.2b2 which at least fixes this issue. If any of you are interested in trying out the new beta, I’d appreciate it.

    updated to 3.2b2, beside the probpem of “no related posts” as said, when we config the YARPP plugin and update its option, there is an error like this:

    Warning: array_search() [function.array-search]: Wrong datatype for second argument in /…/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 428

    many lines like above, on top of YARPP setting page.

    after updating to beta2 the error disappeared 🙂

    Same thing for the one site that had the problem. The beta two solves the problem. Many thanks mitcho!

    I have installed the beta2 version, but still do get this error message, even after deactivating and reactivating the plugin. Any ideas?

    Warning: array_search() [function.array-search]: Wrong datatype for second argument in /home/reasons2/public_html/musicallyspeaking/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 428

    Also, why do the related posts show up twice on my single post page? Please see here:

    Thanks for your help!

    I got the same error as “25reasons” when I installed the beta2.

    For now, I’ve deleted the plug-in and installed the older stable release from the plug-in repository.

    Thanks for the updates and all the hard work!

    Plugin Author mitcho (Michael Yoshitaka Erlewine)


    @mycattom, @25reasons, please try the new development version where I think I fixed this:

    @25reasons, not sure why you’re getting the related posts showing up twice. Does it do that with 3.1.9 too?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] YARPP 3.2b error’ is closed to new replies.