Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] YAARP settings won't stay set

  • The settings in YAARP won’t stay set for me.

    I have tried uninstalling YAARP and re installing it, and I am still getting the same result. Sometimes, the settings change back almost immediately, sometimes they last for a few hours, but always be the next day they have reset to the default settings.

    I am using a custom template for YAARP that goes with my theme (I use the Swift Theme from I am not sure if this has something to do with the problem that I am having. I have talked with the person who made my theme and he says that it isn’t a problem on that end.

    Has anyone else ever had this problem? Any ideas on where I should start looking for a solution?


Viewing 13 replies - 1 through 13 (of 13 total)
  • Hmm, no, this is not something I’ve heard about. Perhaps there are errors on the server side when saving which are not being displayed to you? If that’s so, maybe you can find relevant lines in your server error logs. I’d appreciate it if you found those and shared them.

    Also, try this latest dev version of the plugin: It fixes a few recent issues.

    I’ve been having this same issue for quite a while as well. Without warning, some of the yarpp options get reset, and removing/reinstalling and everything else I have tried has not fixed it. No other plugins I’m using have this problem.

    When it resets it stops using my custom template file, so the related posts are displayed very poorly on my site. Additionally, it makes it so that Bodies and Tags are “do not consider,” so the related posts are not very relevant.

    To fix it I simply access the options through the WP dashboard, switch them back, and save the changes. However, there is no telling if it will switch back later that day or some random time weeks later.

    When it does this, there is also an update message about a “new version of this plugin” at the top of the yarpp settings page, even though I already have the latest version installed. Could it be that it is getting confused about what version it is / is the latest (perhaps if the latest version checking fails) and then it is running some upgrade part of the code because it thinks these are new options were just added and need to be initialized?

    @762mm this is quite odd. Thanks (again!) for your detailed description.

    Some quick thoughts:

    1. Are you running any extra plugins which might modify or even look at other options… something like a backup plugin? (Or if you post the list of your plugins or email me, that would work too.)
    2. Do you have other users who may be reseting the settings somehow?

    Otherwise… huh… this is very unexpected and this is the first time I’ve heard of this. What version of WordPress is this on?

    The “new version of the plugin available” text just tells you that a new version is available… no update code is run when that happens, so your options shouldn’t be getting messed with.

    Mitcho- Thanks for the response.

    No one else has access to the settings. I run two wordpress sites (both use yarpp), but only one is having this problem. I always update the core and plugins to the latest release, so right now I am running WP3.4.2, but I’ve been having this issue for a while.

    I backup the files and DB directly, so I do not have any backup plugins. Here is a list of the plugins used:
    All in One SEO Pack
    Allow PHP in Posts and Pages
    Google XML Sitemaps
    Regenerate Thumbnails
    Term Management Tools
    User Role Editor
    Wonderm00n’s Simple Facebook Open Graph Meta Tags
    WP Super Cache
    WP Widget Cache
    and of course: Yet Another Related Posts Plugin

    Most of these are also used on my other site that doesn’t have this problem, so we can probably eliminate most of them as a potential cause. If we do that, the only ones left are:
    All in One SEO Pack
    Regenerate Thumbnails

    Both of those have been installed on my site for a long time, even before yarpp was installed, so they were definitely around before this issue started with yarpp. (I believe it began around January, but I am not totally sure.)

    I know I tried installing some beta versions of yarpp around that timeframe to try to fix problems I was having with random posts showing no related.

    Here are a few things I have tried, which have not solved this problem:

    1) Uninstalled yarpp and reinstalled.
    2) Deleting all transient data from the DB.
    3) Making basic adjustments to my yarpp settings just to be a little different (i.e. raising or lowering the match threshold a little.)

    Thanks again for the detailed reports. And, just to make sure again, when you save settings in the YARPP settings page, it does look like it gets saved, at least temporarily? You see the new settings in action for at least a little time, and then they reset themselves without your visiting the settings page? Is that right?

    Yes, updating and saving the settings works. Yes, they reset themselves without revisiting the settings page.

    Sometimes they reset a few times a day, but other times it goes weeks without a problem.

    I continue to have this problem. The settings have been resetting a couple times a day for the last few days.

    I am currently running 3.5.3, so at the top of my yarpp settings page it says:
    Yet Another Related Posts Plugin Options 3.5.3

    When the settings reset it then also says the following near the top of the page:
    There is a new version of Yet Another Related Posts Plugin available. View version 3.5.3 details or update automatically.

    However, as mentioned I am already running 3.5.3. If I click the “update automatically” link, it confirms this by saying “The plugin is at the latest version.”

    Any idea why it would say there is a new version available, when I am already at that version? Is there any code related to the version check that would update the settings? Please give me any pointers/suggestions on where to look in the code so I can help debug this.


    Mitcho – I think I finally figured out the root cause. It seems like is blocking my server, so the current version check fails. Perhaps clearing my IP (sent via pm) from your firewall/block list will resolve this issue.

    I’m not sure what it actually returns once it times out, and why that changes settings on occasion. Looking at the code it looks like it should handle this situation gracefully. However, that won’t really be an issue if the server starts returning the correct data for me.

    The issue with my IP being blocked was fixed (thanks mitcho!), and at first this seemed to solve this problem. But when the latest update to Yarpp came down (3.5.5), my settings were reset again. Since then they continue to be reset a few times a day.

    So the root cause to this issue of Yarpp settings being reset lies elsewhere. My guess is it has to do with WP caching the plugin options, and I will post again if I figure it out.

    Thanks for the detailed comments. I’m sorry to hear this is still happening, and hopefully we can figure out its root cause.

    Hi Mitcho. If I wish to display the YAARP output in a different hook position, such as just before the footer, where would I make that change in your code?

    Hi Mitcho. I added “related_posts();” to the hooks php editor and with your instruction to not check “automatically show” and I was able to successfully get YARPP to display precisely where I want – completely after all content – so that the pagination shows properly.

    But in doing so, now the <!--noyarpp--> does not work when I add it to either the comments or the content area. The related posts just keep on showing.

    Any suggestions on this new development?

    Thanks, Alan

    @alberg15 That’s right; the <!--noyarpp--> trick will only affect the “automatic display”. If you are programatically calling related_posts(), you’ll have to do that checking of whether that display is appropriate or not in the PHP code. I suggest you ask someone with some PHP experience to help you in this case, unless you can get around it some other way.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] YAARP settings won't stay set’ is closed to new replies.