WordPress.org

Support

Support » Plugins and Hacks » Yet Another Related Posts Plugin (YARPP) » [Resolved] [Plugin: Yet Another Related Posts Plugin] version 3.4 RSS doesn't show custom text

[Resolved] [Plugin: Yet Another Related Posts Plugin] version 3.4 RSS doesn't show custom text

Viewing 15 replies - 1 through 15 (of 32 total)
  • I just tried this myself but I’m not able to reproduce it. Could you try clearing your browser cache or trying another browser? Also, what do you actually get in your RSS feed now? Is YARPP printing any errors on settings update?

    I disabled the plugin. It was blowing up on my blog.

    Here’s what showed on http://tambnguyen.com/feed/

    This page contains the following errors:
    
    error on line 32 at column 25: Extra content at the end of the document
    Below is a rendering of the page up to the first error.
    
    Tam Nguyen - Sacramento Photographer http://tambnguyen.com Tam Nguyen Photography - Sacramento Portrait, Lifestyle and Wedding Photographer Tue, 13 Dec 2011 16:53:59 +0000 en hourly 1 http://wordpress.org/?v=3.3 Double Exposure: Canon vs. Nikon by Tweakers http://tambnguyen.com/20111213/double-exposure-canon-vs-nikon-by-tweakers/ http://tambnguyen.com/20111213/double-exposure-canon-vs-nikon-by-tweakers/#comments Tue, 13 Dec 2011 16:49:22 +0000 Tam Nguyen   http://tambnguyen.com/?p=2512

    When viewing the source, I saw this:

    32: 		<description><![CDATA[<br />
    33: <b>Fatal error</b>:  Call to undefined method dbrc_wpdb::set_charset() in <b>/home/azn137/www/wp-content/plugins/yet-another-related-posts-plugin/cache-tables.php</b> on line <b>266</b><br />

    I tried resync the feed and clearing the cache with no luck.

    What is dbrc_wpdb? Are you using a non-standard database?

    Not sure, but I DO have “DB Cache reloaded” plugin…

    What’s that GET method to clear the cache of your plugin?

    ?action=flush

    But I’m afraid YARPP won’t work with DB Cache reloaded, as it’s missing an important method in order to be a full replacement for WPDB. I would report this to the author of DB Cache reloaded.

    Ok, disabling ‘DB Cache Reloaded” and re-enabling it helped. I’m now running v3.4, but the custom text for RSS still shows the default text, which is

    <h3>Related Posts</h3><ol>

    instead of

    <hr/><h3>You might also like:</h3><ul>

    Any idea why? I’ve tried clearing the cache a few times, and no, YARPP isn’t printing any errors on settings update.

    Thanks!

    Workaround: I created a custom template and force the plugin to use it in Options.

    Hmm, okay. I still haven’t been able to reproduce your core issue… if someone else can as well, that would be noteworthy.

    Yeah, this version totally hosed my blog with the RSS issues. I’ve reverted back to 3.3.

    P.S.: I was reading other threads that people are posting today. I’ve noticed the “No related post” error as well.

    Thanks for working on the plugin. I’m a developer myself, so I know these things are pretty much unavoidable.

    Sorry to hear that. 🙁 I’m doing my best and always pushing betas, but there always are issues that don’t come up until launch… thanks for your reports and I appreciate your compassion.

    Hello,

    I have issues too since last update.

    I use YARP 3.4.1 on wordpress 3.2.x (don’t remember exactly the version but I’m sure my 3.2 is the last up-to-date version before 3.3). Since I updated YARP this morning, I have this message coming on each posts :

    Fatal error: Call to undefined method dbrc_wpdb::set_charset() in /var/www/virtual/w4a122716/wtcomics/wp-content/plugins/yet-another-related-posts-plugin/cache-tables.php on line 266

    This only occurs when the plugin DB Cache Reloaded Fix (version 2.2.4) is activated, so I suspect a conflict between the two plugins, related to some changes made in the last version of YARP.

    Hoping it will help you to find how to fix this issue.

    Thanks a lot in advance

    Best regards

    DB Cache Reloaded doesn’t have the set_charset method which WPDB does, so it’s failing its duty as a drop-in replacement. I’ll try to contact the author.

    Author contacted via twitter.

    Thanks a lot, I hope this will be over soon 🙂

    In the meantime, I have turned off DB Cache Reloaded.

    @mdatawt: try this version. I added some code to check whether the set_charset method exists first, so it at least doesn’t die when using DB Cache Reloaded:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.zip

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] [Plugin: Yet Another Related Posts Plugin] version 3.4 RSS doesn't show custom text’ is closed to new replies.
Skip to toolbar