WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Yet Another Related Posts Plugin] Using function for YARPP and getting it showing twice

[Resolved] [Plugin: Yet Another Related Posts Plugin] Using function for YARPP and getting it showing twice

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    Sorry to see this… this is quite odd. A couple things:

    1. Please check to see that the “automatic display” option you turned off in YARPP settings is under the “display options for the web” section, and that it stays unchecked after refreshing the page (making sure that the setting is actually being saved).
    2. Are you using a custom template or not?

    Is this an issue that occurred with a recent update to YARPP or your theme?

    finramblog
    Member

    @finramblog

    I was seeing something similar when I switched from Wasabi Related Posts to YARPP. Here was the problem:

    To call Wasabi, I had to use “echo related_posts()” and the “echo” was causing the list to show up twice with YARPP (I call it manually instead of letting it auto-insert).

    The end result looked similar to the problem you’re having, so check your theme and see if this might explain it. Hope this helps.

    Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    @finramblog thanks for chiming in. Indeed, this is a common cause for getting two displays… @kwoodall, is that what your theme happened to do?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: Yet Another Related Posts Plugin] Using function for YARPP and getting it showing twice’ is closed to new replies.