Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] Upgrading from 3.3.3 to 3.4 broke my site

Viewing 15 replies - 1 through 15 (of 16 total)
  • Try installing the plugin via the plugin installer built into WordPress. This has some mechanisms which prevent white screens from happening, and may give you useful information.

    Does your server have a PHP error log?

    As opposed to the automatic update? I already had the plugin installed. I just updated it.

    I’m sure my server has an error log, but I’m with Zippyzid for this account, and while they are AMAZING, you don’t get instant access to things like that with them (It’s really a managed WordPress host).

    For the time being I reverted back to version 3.3.3 of the plugin and will probably just leave it there.

    ** I know you can’t account for every combination of plugins, but updating plugins on a production site [this one gets 700,000 page views a month] is sometimes hairy, and really shouldn’t be. I wish there was a really solid Sandbox that would literally mimic an online site, so I could face white screens at my leisure!

    What I meant was to delete the plugin and then reinstall it via the plugin system. Upgrades don’t get sandboxed the same way that new plugin installs do.

    I have the same issue on another site (also with ZippyKid… who I work for actually). It seems the plugin download doesn’t have the includes.php file and so the require_once is throwing a fatal error.

    Warning: require_once(/home/XXX/websites/XXX/htdocs/wp-content/plugins/yet-another-related-posts-plugin/includes.php): failed to open stream: No such file or directory in /home/XXX/websites/XXX/htdocs/wp-content/plugins/yet-another-related-posts-plugin/yarpp.php on line 15 Fatal error: require_once(): Failed opening required ‘/home/XXX/websites/XXX/htdocs/wp-content/plugins/yet-another-related-posts-plugin/includes.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /home/XXX/websites/XXX/htdocs/wp-content/plugins/yet-another-related-posts-plugin/yarpp.php on line 15

    Where does this file come from?

    I should note that I downloaded the plugin from the admin interface after deleting the existing one. It won’t activate because of that error.

    Ok… so updating to WP 3.3 seems to fix the issue with YARPP 3.4 throwing a fatal error. Not sure if this is intended to break the backwards compatibility, but that’s what I’m seeing.

    This is very strange… there is no reference to yet-another-related-posts-plugin/includes.php on yarpp.php line 15, at least not in YARPP 3.4. In fact, includes.php no longer exists, so it seems like your distribution is acting oddly… it deleted includes.php but retained the old yarpp.php.

    When was it removed? I’m wondering if it’s a caching issue on our hosting setup that’s still asking for it… was it in version 3.3?

    Yes, YARPP 3.2.1 and earlier included an includes.php, but YARPP 3.3 (and most of its betas) lack an includes.php.

    It looks like it was a caching issue on our end. When we updated to 3.4 for some reason it was still looking for the includes file. Purging the caches and then activating the plugin worked for us.

    Thanks for the awesome support!

    YARPP also white-screened my wordpress site. But I found by deactivating the Related Post Slider, everything works ok. So perhaps the problem is with Related Post Slider.

    Indeed, Related Post Slider doesn’t support YARPP 3.4.

    @mitcho My incompetence and the difficulty of working behind a heavily cached site meant that many things went pear-shaped a few days ago. But until now I get a “No related posts” response from YARPP, whereas earlier it was working fine. Do you have any tips in troubleshooting this? I’m a beginner, so pls bear that in mind in your response. Thanks, and thanks for a great plugin

    @immanence two things:

    1. make sure you’re using the latest version of YARPP. I suggest you use the latest beta:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.3b2.zip

    2. Try lowering your “match threshold”. In the YARPP options page, click on screen options and then “relatedness” to display the “relatedness” options. The default “match threshold” is 5; try two or three. Update at the bottom of the page, then check some of your posts to see whether you’re getting any related posts. Make sure you’re bypassing any caching when you do this.

    @mitcho I tried both of those, and no difference

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Upgrading from 3.3.3 to 3.4 broke my site’ is closed to new replies.