WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Yet Another Related Posts Plugin] Upgraded to 2,0 – now not working

[Plugin: Yet Another Related Posts Plugin] Upgraded to 2,0 – now not working

  • Hi,

    I just used “automatic upgrade” to take me to v2,0 of YARPP and now it’s failing to work. The admin page comes up fine, but I get either “no matching results” or a PHP error (see below) depending on the options I select within Titles/Bodies/Tags/Categories. If I select any of them to any degree, I get simply “No related posts.” I’ve tried dropping the relevance from 3 (where it worked before) to 0.1!

    If I set all four to “Do not consider”, I get the following error again followed by “No related posts.”:

    Warning: Division by zero in /homepages/8/d151455252/htdocs/Moshtour/wordpress/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 85

    Either way, no joy – a shame as the previous version was great!

Viewing 15 replies - 1 through 15 (of 42 total)
  • Just upgrade from 1.5.1 to 2.0 and now no related posts shows in all of the posts, with 1.5.1 it works perfectly, is there something to adjust so it work again, does the code for the theme change ? as in the other notes there is no example, as the faqs of the plugin says.

    Thanks.

    I installed the 2.0 version first and it doesn’t display any. When I installed the plugin I got these errors:
    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/addonsfi/public_html/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 63

    Warning: Invalid argument supplied for foreach() in /home/addonsfi/public_html/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 63

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/addonsfi/public_html/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 67

    Warning: Invalid argument supplied for foreach() in /home/addonsfi/public_html/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 67

    Hopefully it should help in tracking down the problem

    Using PHP5 in safemode

    Hi all, thank you for your feedback.

    @iainpurdie I guess I should fix that divide by zero possibility, but the idea is that you would never choose to *not* consider all of the criteria… I personally had to adjust the threshold slightly this version, but I’m surprised you’re not getting any results with 0.1! I would recommend turning on “consider post content” and nothing else with some low threshold value and see what happens… As a last resort, have you tried removing the plugin and installing it again? I’m curious to know if that would fix it.

    @polle1 The code did not change, so your theme should be fine. The question may be your threshold, as noted above… I would recommend making it really low, checking what is displayed (with the “show match scores for admins” option on) and finding a new threshold.

    @cdsanchez I’ve just corrected that bug (a simple variable scope issue) as version 2.0.1, even though wordpress.org isn’t updating… you can download it here.

    Same issue as Pollie. All results are no related posts found…

    And I have the threshold at 0.

    TeraS

    Oh… And I also get this error:

    Parse error: syntax error, unexpected T_DNUMBER in blog/wp-content/plugins/yet-another-related-posts-plugin/includes.php on line 63

    TeraS

    I’m getting the same T_DNUMBER error as terasuccubi. Upgraded from 1.5.1 and it won’t activate now as it causes a fatal error.

    Upgraded to 2.0.1 and I also get the T_DNUMBER error as well.

    Whooop! I just introduced that bug by actually calling this version 2.0.1, which isn’t a real number… who knew!? Sorry about that… here’s [version 2.0.2](http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.2.0.2.zip).

    mitcho

    I am having the same issues. And 2.0.2 does not work. Borken php pages and “No Related Posts” displayed.

    I am on php5 mysql5 apache4 wp2.5.1

    @phorbidden, can you tell me how the php pages are broken? Thanks–

    mitcho

    I don’t get anything, right when it hits the PHP tag to related_posts() it dies… on index.php

    But on my home.php page it process with “no realted posts”

    Hi, I did test changing threshold and none, just a “No related posts” message.

    If I reupload 1.5.1 it works again.

    This 2.0.2 has something new that 2.0 dont ?

    Thanks.

    I am trying some echos… but I am finding absolutely nothing. Would updating the DB to UTF-8 be an issue?

    @polle001 2.0.2 fixes a couple crucial bugs… so does 2.0.3, which I just released. Download 2.0.3 here.

    @phorbidden. 2.0.3 *may* fix your problem as well, though I’m not sure… my db isn’t natively in utf8 but that hasn’t been an issue for me myself… are you sure there are no errors printed to the source?

    I’m so sorry for all the bugfixes… I’ll try to resolve all of these asap!

    mitcho

    Just replaced it and the same “No related posts”. I havent change a thing and nothing.

    Changing threshold does not help.

    Any ideas ?

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Upgraded to 2,0 – now not working’ is closed to new replies.