Support » Plugins » [Plugin: Yet Another Related Posts Plugin] Upgrade to R3 gives include error

  • It was working fine on release 2.1.6, and I upgraded to 3.0/ Now I get the following error:

    Warning: include() [function.include]: Failed opening '/Applications/MAMP/htdocs/wp-content/themes/thesis/' for inclusion (include_path='.:/Applications/MAMP/bin/php5/lib/php') in /Applications/MAMP/htdocs/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 300

    Can you help me?

Viewing 12 replies - 16 through 27 (of 27 total)
  • Upgraded to 3.02 and saved the options as mitchoyoshitaka told us, the problem is now solved. Thanks mitchoyoshitaka.

    Actually, not everything is allright. The version 3.02 still introduces a weird bug where special characters like ã, á, ü, ó, é, etc. are wrongly encoded to ISO-8859-1 instead of UTF-8 when I publish a new article. That doesn’t happen when the plugin is disabled.

    I’ve had the same problem as others have had: the include() error, before saving the options and moving the template files with version 3.0.2. I had to take those steps before 3.0.2 would work for me.

    Additionally, the plugin contains this line in includes.php:
    require_once('services.php');

    I happened to have a file named services.php from the previous (non-WP) version of my site in the site’s root directory. *That* file was included rather than the one in the YARPP plugin directory. Renaming my services.php got rid of this particular include problem, but I figured you’d probably want to be alerted to this behavior nonetheless.

    Congratulations on a brilliant plugin, and I look forward to tinkering with the new template feature. 🙂

    I have installed 3.02 and have a new problem. I got it installed, and the first time I went to a post to see how it is working, it gave what looked like the same error. So I went to the plugin’s setting and clicked the button to update the settings. Then at the top of the page it said something was not complete, something about my cache, and asked me to click to continue. I did. It started building my cache, got to 61.4%, stopped building, and a message came up “Try to Continue”. When I click on that it just comes right back up again. I cannot get it to finish.

    The posts show related posts, but I fear it’s calculating a lot of that on the fly. How can I get it to complete building my cache?

    (I have about 800 posts. It is on a dedicated server, and is fast.)

    Update to post above:

    The cache building seems to run for exactly one minute and then stops. Every time I go back to the cache status link, it comes up at the same percentage completed and is still hung up.

    But then, if I go to the bottom of the options page and click Update Options, I get a message that says “Your cache is 96% complete.” with a button to “build the cache now.” When I click that it starts at zero again and the whole process continues all over again.

    @g33kg0dd3ss thanks for the services weirdness… that’s odd, though, but it must have something to do with your PHP include path.

    I wanted to let everyone know that I accidentally did *not* include my 3.0.1 patch in 3.0.2… so the include bug is back. To fix it, go to your YARPP settings and save it once. That should do it. Sorry about that–it’ll be for sure included in the next bugfix.

    @slobizman – you can’t close the cache status window… maybe that’s the problem. Alternatively, if you leave the “on the fly” option on, it’ll naturally build the cache over time, which may be safer. If you go to 96%, for example, and leave the “on the fly” option on, if a visitor visits that other 4%, it will build it when that happens.

    Thanks for the reply. I didn’t close the status window until it was stopped for at least a half hour.

    So, do I just ignore the following message at the top of the Plugin options page for as long as I use it without worry? Will it ever go away?

    “Your Related Post cache is incomplete. Please build your cache…”

    @slobizman – if you have the “on the fly” option turned on, you can safely ignore that warning… perhaps I will make that notice less warning-looking in the future.

    I have another problem after upgrade to YARPP 3.0.x
    I’m still using WordPress 2.7, after I upgrade to 3.0.x, my “Users” page in the WordPress admin page doesn’t display anything. After I deactivate YARPP, the Users page comes back with the list of users.

    @rainbow_star – huh, that’s completely bizarre… I don’t have any idea off the top of my head why that would happen… what other plugins are you using? Anything that updates the Users screen?

    @rainbow_star, could you start another topic in the forum here with this question? Perhaps someone else has the same problem.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Upgrade to R3 gives include error’ is closed to new replies.