WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: Yet Another Related Posts Plugin] Since 2.8.2 update admin settings page doesn’t load

[Plugin: Yet Another Related Posts Plugin] Since 2.8.2 update admin settings page doesn’t load

  • Since updating to WordPress 2.8.2 (and 2.8.3) when I click on the link in the sidebar to access the plugin’s settings, the page itself doesn’t load correctly. The regular WordPress sidebar loads but the content where I’m used to seeing options to control YARPP is entirely blank. I suspect this is something to do with the elevated permissions introduced in the last two WordPress updates but I’m not seeing anyone else reporting this issue so I’m not sure what the problem is.

    It’s only begun happening since I updated. I have it running on another machine however which updated from 2.8.1 to 2.8.3 with no issues, so I’m not sure what the problem is. This has persisted between deleting and reuploading the plugin and has only manifested in the last couple of days.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Actually I can give a quick update. The machine that was running 2.8.1 with no issues upon updating to 2.8.3 was running the plugin at 3.0.7. When I updated the plugin (after updating to 2.8.3) so it was at 3.0.8, the plugin stopped working on the machine that had worked previously.

    When I tried to roll back to 3.0.7, the problem still persisted and continues to be present back with version 3.0.6 as well.

    I will point out that the plugin itself still works correctly and returns correct results, I just can’t access the admin page to change any of the settings.

    I’m also having this problem since the upgrade – has anyone found a fix because I want to change the amount of related posts shown.

    Thanks

    @mixvio you mentioned this may be a permissions issue—what permission level is the user you’re using to test here with?

    I meant the elevated permissions changes WordPress added in 8.2.2 and 8.2.3 to fix an exploit in the admin panels.

    I run my site on a dedicated server, I have complete control over all of it.

    Is a fix coming for this? If necessary I’m happy to provide whatever logs you need that can help the issue or whatever I can do to expedite your debugging. Just tell me what you need.

    sami82, are you running Pagebar 2? I just discovered that the conflict happens once I activated that one. I shut off all the plugins on my site and turned them on one by one, and it stopped working when Pagebar 2 was also turned on.

    The problem with conflicting functions in pagebar and YARPP will be solved in the next version of pagebar coming next week.

    Great to hear Latz, thanks for the update.

    Happy to confirm that since the Pagebar2 update today, the plugin’s admin panel is once again working normally.

    Thanks so much you guys.

    Latz, thanks for the update!

    Mixvio, thanks for bringing this to our attention! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Since 2.8.2 update admin settings page doesn’t load’ is closed to new replies.