Support » Plugins and Hacks » Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] Settings page broken

  • The settings page doesn’t work at all on WordPress 3.0.5 (multisite).

    The settings page is blank. And JS is definitely broken as the admin menus in the left sidebar do not open or close.

    The JS Console shows something like:

    ReferenceError: Can’t find variable: postboxes

    I tried deactivating all my plugins, mu-plugins, and drop-in plugins.
    Still no dice.

    Maybe the options rewrite has not been tested on WP 3.0.x

Viewing 15 replies - 1 through 15 (of 19 total)
  • Downgrading to 3.2.2 worked for me.

    Hi,
    Thanks for this. I have the same: a blank settings page. I am in WordPress version 3.0.4. The Related posts works fine, it does show a lovely list at the bottom of each post.

    Is this blank page happening to all wp-admin pages? or just the YARPP options page?

    This is just for the YARPP options page.

    You still get:

    Yet Another Related Posts Plugin Options 3.3.1
    by mitcho (Michael 芳貴 Erlewine)

    and the two sidebar widgets “Contact” and “Upgrade to BlogGlue”

    But the rest of the page is blank, and because of the JS problem, the menus on the left don’t toggle open-close.

    Mitcho, In my case it is the only WP admin page that is blank. I can select ‘Related Posts – Yarpp’ in the Settings menu. It comes to this blank page headed:

    Yet Another Related Posts Plugin Options 3.3.1
    3.3.1
    by mitcho (Michael 芳貴 Erlewine)

    And then on the right hand side it has the two sidebar widgets: Contact Yarpp and Upgrade BlogGlue.

    I realise now this is exactly the same as the person above is describing. I hope you have some ideas as to how to solve it, that would be ever so amazing.

    I’m experiencing the same behavior with YARPP 3.3.1. Nothing in the YARPP options panel. I have also tried clicking “Screen Options” while on the YARPP plugin options page and nothing happens.

    No other plugins or admin panel functionality is affected in this way.

    WordPress version = 3.0.4
    Browsers = Chrome, Firefox

    Thanks for all the reports. Are you all getting the error “ReferenceError: Can’t find variable: postboxes” in your JavaScript consoles?

    Are you all on WordPress 3.0.x?

    Mitcho: I’m on 3.0.4 (NOT multisite). I’m getting this error, when I run Firebug

    “postboxes is not defined
    postboxes.add_postbox_toggles(pagenow); ” (line 229)

    Hope that helps. Thanks for your work on an otherwise excellent plugin.

    Got the same problem – which is a shame as it’s a dead handy plugin. huyz, you said you downgraded to 3.2.2 and it’s all good? Now, I’ll sound like an amateur, but how do I downgrade the plugin?

    G

    (BTW I’m running WP 3.0.1)

    @guy Just downgrade the same way you would upgrade: replace the directory in plugins/ with the 3.2.2 code

    Cheers for that – and this might be dumb – but where do I get the 3.2.2 code?

    Not a dumb question. I also asked a few weeks back.

    Every extension has an “Other Versions” link at the right below the ratings. Or just add “/download” to the URL of the extension.

    For this plugin, http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/download/

    Hi mitcho, I’m on WP 3.0 and I got “Uncaught ReferenceError: postboxes is not defined”.

    Bye, Francesco.

    bump

    Hi all, I believe I just fixed this issue in the latest dev version. Please try it out:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.zip

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Settings page broken’ is closed to new replies.