Support » Fixing WordPress » [Plugin: Yet Another Related Posts Plugin] problem showing the single post page

  • im using wp v2.7, and i recently installed the YARPP plugin version 3.0.6 which i think is compatible with my wp version.

    I put the plugin as a widget, displaying at the single post page.

    The problem is that although the results of the related posts are great, everytime im trying to see a post single page i get the message

    “Not Found

    Sorry, but you are looking for something that isn’t here.”

    When i deactivate the plugin, the single post page works great.

    I found somewhere a complain like mine, i tried to do something within the phpMyAdmin, but the thing is that i dont know quite well these stuff, is there anything i can do to fix this?

    thanks in advance.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter nikrho


    i upgraded to wp 2.8, still the same problem…

    anyone who knows whats wrong?

    thanks in advance

    Me too. I just upgraded yarpp and it breaks the single post page.



    I have the same problem. Everything else is working but when you click one of your posts to go to single post view the “Not Found” is printed instead of your post.



    Same problem, but only for the last few days. Using WP 2.8.3 and YARPP 3.0.8

    Hi all— I’m hoping to correct this issue very quickly.

    Are all of you using YARPP as a widget? I believe that may be the common thread here.



    Mitcho – I see no one’s gotten back on this. But I will. I’m having the same issue. Yes, I’m using the widget. I’ve also noticed if I used the default theme, there is no problem. So it’s been my belief (over the last week) that it’s my theme. However, I’ve been poring over the code and can’t figure out where the conflict is, since my single post page is pretty standard. The only difference is that on both template files (single.php and yarpp-template.php) I’m using custom fields to pull in some specific information for the theme. But again, the methods I’m using to do this are pretty standard.

    If it would help to look at the files I’m using, I’d be happy to pass them along.



    I believe I’ve found the issue. This is just an initial thing – but when I commented out *one* single line in the yarpp/includes.php file, my single posts magically reappeared, and the YARPP contiues to work just fine. Of course, I *just* now saw this happen, so I need to test it to be sure, but if you ant to look at it, it’s line 223 in /yet-another-related-posts-plugin/includes.php

    the line is this:


    basically, I think what’s going on is you’re not *getting* the post, you’re *echoing* it. So it’s conflicting with that’s in the actual content area. if I change it to “get_post($post->ID);” it works a treat.

    Again – I still need to wade through and test it more – but it looks like this is the issue.



    Oh, I should also note that when I suspected it was a widget issue, I tried hard-coding the call to the function in my sidebar.php file and I *did* have the same issue. Sorry, I should have mentioned that earlier. So I don’t think it’s a widget-only thing.


    Thank you so much for getting that bug fixed. My blog is now relating posts once again. You’re a good man.

    @doodlebee, thank you for your investigation here! I’m going to incorporate that change in a quick update.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] problem showing the single post page’ is closed to new replies.