Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] Plugin installer reports extra charac

  • Having just cleaned out a hack on this site I’m very sensitive to funny behavior by plugins. The Wprdpress plugin installer reported 116 extra characters generated during activation and warned if I see “header already sent” warnings that I should deactivate it. Since that is exactly what I saw when the site was hacked (that message plus long lists of links to Pharama sites added to every post) I immediately deactivated it and started looking for backdoor files.

    Haven’t found any yet, but what’s going on?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Not sure, and unfortunately I have no way of diagnosing your particular issue without knowing what those 116 characters were. 🙁

    If you feel unsure, make sure to download the plugin directly from the site:

    Same problem here: wordpress 3.0.4 with php and mySql both current versions.
    1- installed using auto-install from plugins admin, Add New.
    2- installation reported “extra characters…header” etc about 116 chrs (sorry did not capture that, then).
    tried to load ‘settings’ page from plugin admin – never loaded.

    3- Deactivated plugin, waited ~ 10 mins.
    Reactivated plugin and NO ERROR Messages during Activation.
    tried to load ‘settings’ page…never loaded (browser Mozilla page loading icon just spinning – no timeout message after 4 minutes). Trying Delete Plugin then reinstall next

    4- Deleted plugin, (removed all files. yes all were in the plugin’s folders).

    5- tried automatic install again – via Add New.
    Successfully installed the plugin Yet Another Related Posts Plugin 3.1.9.
    clicked “Activate Plugin” No Errors – Yea!
    from Plugins Page, clicked ‘Settings”
    Oops! well it started to load up; showing spinners in the categories list and tags list areas, etc. Then the page goes blank. Pressing the Back-arrow on the browser begins to draw the ‘settings’ page but the areas with variables (categories list tags list etc) showing only spinners and after a few seconds the page goes blank – yikes!

    6- trying in Chrome browser instead of Mozilla 3.x
    navigated directly to the Plugins page. Clicked ‘Settings’ pages begins to appear (again, with spinners in the area of the page titled, “The Pool”
    After a few seconds the settings page goes blank

    7- … Hope to see some suggestions about this in the future here on this forum.

    This plugin works well and without any problems whatsoever on other blogs i manage,l but not this blog… sorry, don’t have the time to deactivate every plugin and see if one is conflicting (a likely cause me thinks)… I’ll check back soon 😉

    I’ve used this plugin on dozens of sites, but today I attempted to add it to a site running on HostGator share servers (I almost always use Hostgator). Running it with the latest version of the StudioPress Sleek child theme and wordpress 3.0.4

    I had a very similar experience to gobigreenwood.

    Couple extra points, I got the extra character message, but there was no list of what those extra characters were anywhere that I could see.

    I was able to go through the setting successfully, and it did correctly add related posts to the site.

    However, the load time for the site went from 4.6 seconds to 30+ seconds!

    I’m using Hypercache extended on this site (getting better results with that as opposed to Super Cache). I mention that because I noticed on the YARPP plugin developer page, that it recommends Supercache.

    I’m curious if maybe the new YARPP built in cache might have a conflict with Hypercache extended or maybe non Super Cache plugins?

    This is a great plugin, and hope that we find a solution to fix this soon! 🙂

    hi there,

    i have trouble in installing any kind of plugin ….please help me for that

    there were message like this:

    Unpacking the package…

    Installing the plugin…

    Destination folder already exists. /public_html/wp-content/plugins/WPRobot3/

    Plugin install failed.


    but there was no list of what those extra characters were anywhere that I could see.

    Yes! That’s the annoying thing about this issue… I’m unable to ask for this information from you, so it’s really hard to diagnose this issue remotely. 🙁 I’m about to push YARPP 3.2, though, and I believe it may fix this issue. Please try it out.

    @parta, it looks like your WP is trying to install a plugin called WPRobot3, not YARPP. Looks like a problem with WP or that plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Plugin installer reports extra charac’ is closed to new replies.