WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Yet Another Related Posts Plugin] Plugin Admin Error after Upgdate

[Plugin: Yet Another Related Posts Plugin] Plugin Admin Error after Upgdate

  • jamirdesign

    @jamirdesign

    Below is what I got in the admin panel of my Plugin page after I hit update Plugin…

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'yarpp_settings_link' was given in /home/XXXXXXX/public_html/wp-includes/plugin.php on line 166

    while this is what I’ve seen below each Plugins…

    Warning: Invalid argument supplied for foreach() in /home/XXXXXXX/public_html/wp-admin/plugins.php on line 437

    The “Activate” “Delete” and etc is gone.

    Please help!

    Thanks!

Viewing 15 replies - 1 through 15 (of 16 total)
  • jascanio

    @jascanio

    Same issue here…running WP 2.8.2

    I was, however, able to select the plugin and deactivate it. Once deactivated, everything went back to normal.

    I would like to continue using the plugin, though, so hopefully there will be a fix available shortly!

    jamirdesign

    @jamirdesign

    hoping to fix this asap!

    Same issue here. Had to deactivate until this issue is fixed.

    @jascanio I noticed you said you were using WP 2.8.2. You REALLY need to upgrade to 2.8.4, right now your site is vulnerable to the new worm that is hitting WordPress http://bhnet.me/2h

    jamirdesign

    @jamirdesign

    thanks for the info bhelms!

    yes and I’m using 2.8.4

    jascanio

    @jascanio

    @bhelms -id LOVE to but so far my host, Media Temple, has not made that version available via their one-click install interface.

    marcfuller

    @marcfuller

    Same issue as the OP here, too. Embrace teh suck!

    jamirdesign

    @jamirdesign

    Wow! That was fast!

    Thanks YARP!

    jascanio

    @jascanio

    Did something happen that i missed? I am not seeing any updates….

    jamirdesign

    @jamirdesign

    Check your WordPress Plugins Admin Panel Version 3.0.13 is now available.

    jascanio

    @jascanio

    Just did…nothing.

    marcfuller

    @marcfuller

    3.0.13 – Fixed the issue that I shared with OP. Now conflicts with Featured Content Gallery.

    Wish I could go back to the earlier version.

    Thanks for this. All sorted.

    jascanio

    @jascanio

    Unfortunately the plugin update option is not showing up in my admin area (currently working fine for other plugins, however).

    jascanio

    @jascanio

    Well, bit the bullet and did a manual upgrade, sans-Media Temple. Oh, and now the Plugin option is back! Woo hoo!

    Hi all— yes, I fixed this immediately last night an hour after pushing 3.0.12. I guess using the beta builds were a good idea after all… I apologize for the initial confusion.

    In other news, @marcfuller, what conflict is this? Could you start another thread for it?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Plugin Admin Error after Upgdate’ is closed to new replies.