Yet Another Related Posts Plugin (YARPP)
[Plugin: Yet Another Related Posts Plugin] Not working, version 3.4.1 and custom template (44 posts)

  1. José Luís
    Posted 3 years ago #

    @mitcho, first, thanks for your assistance! I know these requests (especially after 3.4) can be overwhelming! Great job!

    About the maximum, I know it will sound weird but this morning it seems to be working fine. Is it possible that, although I did not flush it before going to bed, during the night the cache was updated?

    About the $related_query-> references, YARPP did not work without removing all $related_query-> references (it took forever and tried to show the same related post entry infinite times). Should I leave it without the references?

  2. infolotnicze
    Posted 3 years ago #

    The plugin started to work for after the update to 3.4.2 but now it doesn't work anymore ;(


  3. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 3 years ago #

    @frudrew do you have trouble changing your template? or is the issue that you just don't get any results in your custom template?

    @Fumiki the issue is that, by just calling the the_content filter directly without being part of a loop, it's not setting up the right ID variables. You probably need to do something like setup_postdata($price). But the safest way to do it would be to call up your prices using a real loop, using query_posts() and then have_posts() and the_post().

    @José thanks for the report. I'll look into the $related_query-> references, but just removing them should work. I will have to look into it for the future.

    @infolotnicze what problem are you having now?

  4. infolotnicze
    Posted 3 years ago #

    They do not showu up. I had to install another plugin. The strange thing is that they show up in older posts:
    but from a post from today I dont have them. Just the standard info that there are no related posts:

  5. frudrew
    Posted 3 years ago #

    Hi Michael!

    I have a custom template which I've changed in the appropriate places but is just not showing up on the actual settings page. Instead the default one is there.
    Am at a loss as to how to carry the template over. It worked before.

    Thanks :)

  6. José Luís
    Posted 3 years ago #

    @mitcho, AFAIK, YARPP is now working fine on my blog (even with DB Cache Reloaded Fix enabled). I'm writing this just to report something I forgot to mention about the maximum number of related posts:

    - when YARPP was showing at most 5 related posts, YARPP Experiments Cache Status informed the sequence 0 to 5 under "Number Related". Now that it shows up to 6 related posts, Number Related shows a sequence of seven pairs of numbers, from 0 to 6!

    Now some questions about this: is this related with my previous problem? If so, does it mean now my maximum is six related posts at a time?

    And finally, a suggestion: why don't you implement YARPP Experiments features under YARPP? They could be disabled by default and advanced users could enable them when needed...

  7. José Luís
    Posted 3 years ago #

    BTW, I forced the full generation of the cache (using the button available on YARPP Experiments) and the final data (at this moment) are:

    Cached: 100%
    Cache type: custom tables

    Number related:
     0    1    2    3    4    5     6

    87  20  17  23  21  10  266

    Generation dates:


    Score (among those related): avg 24.687, sd 15.008

    What does these mean?

  8. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 3 years ago #

    Hi all, if you're having trouble getting related posts to new posts you write, please try this new beta:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.3b1.zip (link will work in a few minutes)

  9. frudrew
    Posted 3 years ago #

    Legend Michael! You're awesome! Thank you soooo much :)

  10. infolotnicze
    Posted 3 years ago #

    The 3.4.3b1 doesn't work. Maybe I have to change something in w3 total cache or somewhere else.

  11. Breacan
    Posted 3 years ago #


    I appreciate your hard work on dealing with these issues.

    I have installed 3.4.3b1 and am still having the same issue that most others are. No error messages occur and pages are displayed correctly, but I am not seeing any related posts being found.

    I am running w3 total cache using xcache as my caching method.

    I installed yarpp experiment:
    I flushed the cache and after pressing the generate cache button received the message "Cache computation ended prematurely. Try reloading the page and continuing." multiple times before finally finishing.

    After doing this, already published posts appeared to have related posts attributed to them, but when I created a new post it would always show "no related posts".

  12. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 3 years ago #

    @infolotnicze you will also want to flush the cache, which you can do with the YARPP Experiments plugin. Could you then see if you get results in both new posts and old?

    @Breacan the generate cache button dying isn't a terrible concern for me personally, as YARPP should work fine without manually building the cache that way. Since 3.4.3b1 didn't help you get results on new posts, I would suggest you try lowering your match threshold.


  13. infolotnicze
    Posted 3 years ago #

    Hello mitcho!

    Strange thing. I've instaled the beta and it works on latest post. hmmm I will also test the YARPP experiments. Thanks for your effort with helping me and others with problems!

    E. Dumb question. Will I be able to update the plugin from the beta?

  14. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 3 years ago #

    @infolotnicze Wonderful! Yes, you will be able to upgrade to 3.4.3 final as well as to future new versions. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic