Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] Not working, version 3.4.1 and custom template

  • After i updated plugin half hour ago, it’s stoped showing related posts. I”m using custom template and WordPress 3.3. Also, i cant see related posts even on edit page in that metabox, and after i make some changes and update post.

    If you want, i can include my custom tempplate in my next message.

    Also, i found another bug with your custom test template for random (yarpp-template-random.php). You’re using just <?php query ?> instead of <? WP_Query ?> and that shows up an error when no related posts are found out.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

Viewing 15 replies - 1 through 15 (of 43 total)
  • Same here.

    Same here, updated to latest version and now have no related posts anywhere.

    Has all been working OK over last year and more than 100 posts.

    WordPress 3.3 and custom template

    Match threshold 2
    Titles do not consider
    Bodies do not consider
    Categories do not consider
    Tags require at least one Tag in common

    “After i updated plugin half hour ago, it’s stoped showing related posts.”

    I have this problem also. But i’m not using custom template

    Same here — custom template, self-hosted WordPress installation, upgraded WP to 3.3, upgraded YARPP to 3.4.1, then related posts disappeared (as in: whereas with previous versions I had plenty of matches, now I have none — 900+ posts). I’m also running qTranslate, with content in English and Japanese.

    Match threshold: 1
    Titles: Consider with extra weight
    Bodies: Consider
    Categories: Consider
    Tags: Do not consider [I don’t use tags]

    I got Experiments and have tried rebuilding the cache with different Relatedness options, but no luck.

    Same and also the plugin options screen seems to be broken (less options and toggles not working)

    I’m sure mitcho will answer this soon, but for now have you guys tried 3.4.1b5? It fixed many issues for me.

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.1b5.zip

    b5 seems to be an older version than the straight 3.4.1? According to my install anyway.

    Made no difference to the plugin option screen. Still broken.

    You’re right, sorry.

    Yarpp dosen’t work, but it’s OK. It means extended feature is useless.
    What the most terrible is Yarpp breaks normal post_content.

    Here’s example.

    I’m plugin author and my plugin have price a list page with custom post type named ‘subscription’.
    This is very simple.
    This list is created by wpdb->get_result and foreach. Not wordpress loop.
    But as a result, apply_filter(‘the_content’, $post->post_content) returns anothor posts post_content.

    I think WP3.3 changes loop structure so that Yarpp has been broken.
    I hope it will be fixed soon.

    b5 didn’t make a difference for me, so activated debug…

    WordPress database error: [Unknown column ‘wp_posts.ID’ in ‘on clause’]

    Sounds like “wp_” was assumed to be the default prefix even though it’s not the case on my wordpress instance…

    @djevrek thanks for the bug report on yarpp-template-random.php . Does it work for you if you change it to query_posts instead of query?

    @the1path I think you have a totally different problem… I’ve responded to you in another thread.

    高橋さん、 are you using YARPP 3.4.1? YARPP 3.4 had an issue with the $post reference.

    @goormand you’re totally right! Thank you, and my apologies. I just fixed this and pushed a 3.4.2b1:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.2b1.zip (try link in a few minutes)

    Works now…

    Fantastic, thank you! Will push out 3.4.2 in a bit…

    sorry to be bring bad news, I downloaded 3.4.2b1 and it didn’t work and have just tried the 3.4.2 available via wordpress plugin downloads and it still doesn’t give any related posts.

    http://www.harrogate-news.co.uk is the website

    Have sorted, installed YARP Experiments and cleared the cache.
    Great plugin!

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Not working, version 3.4.1 and custom template’ is closed to new replies.