WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Yet Another Related Posts Plugin] No related posts

[Resolved] [Plugin: Yet Another Related Posts Plugin] No related posts

Viewing 15 replies - 1 through 15 (of 35 total)
  • NeverChill
    Member

    @neverchill

    Having the same problem, have had it for quite a while now. When previewing a post the related posts show up fine, once the post is actually published there are no results.

    This seems to happen randomly and is immediately fixed by hitting Update on a post, even though nothing has changed.

    I have installed the experimental plugin as well and have Flushed and rebuilt the cache several times to no avail.

    Yet Another Related Posts Plugin Options 3.5.2 with YARPP Experiments 0.6

    Please help!

    Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    I’m sorry to hear you’ve had issues like this, even with 3.5.2. I’ve heard of reports like this but have been unable to reproduce this issue. I’d appreciate if you could help me

    1. WordPress version
    2. Have you manually changed your YARPP_CACHE_TYPE? (If you don’t know what this means, you haven’t. :))
    3. server environment: shared hosting or private server, PHP and MySQL version (if known)
    4. caching system? e.g. W3 Total Cache, Super Cache, memcached, or something else?

    @zenkaty and others: is your behavior just like @neverchill described, where drafts show results, published posts lose them, then updating can make them appear again?

    I really would like to resolve such issues and would appreciate any information I can get.

    Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    Please also try this latest beta, which may resolve this issue in some cases: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.3b1.zip

    Thank you!

    zenkaty
    Member

    @zenkaty

    I have the latest version of everything. Haven’t changed YARPP_CACHE_TYPE. The site’s on a VPS running Zeus, MySQL verison 5.2.17. No caching as far as I know. I have just tried editing, saving, previewing, on drafts and published files, and got no Related Posts anywhere. I am running other installs in a similar, if not the same, environment and YARRP works perfectly. So there’s something about this particular thing that’s breaking it, but I can’t figure out what!

    Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    @zenkaty did you try the latest beta? Is there some particular plugin you’re running on that install but not other, working installs? It’s possible that this is a plugin incompatibility.

    NeverChill
    Member

    @neverchill

    Here’s my info:

    1. WordPress 3.2.1
    2. No change
    3. VPS running MySQL 5 and PHP 5
    4. WP Super-Cache

    Thanks for looking into this!

    juninho_14
    Member

    @juninho_14

    I also had this problem.

    im using the function related_posts(); just.

    When i updated the plugin all the related posts are gone. Now i just have the message “there arent related posts”.

    Maybe a new upgrade resolve this problem? Did anyone solved this bug already?

    Ps.: wp and plugin is up to date.

    zenkaty
    Member

    @zenkaty

    I am now running the beta – still no related posts.

    No difference if I insert automatically, or use the code in my template. Any text in the “no related posts display” shows, the link to YARRP shows if I check it – just no posts.

    Just updated to new version (and newest WP version)

    Having the same issue… any updates?

    nhowarth
    Participant

    @nhowarth

    I was having this problem with 3.5.2 – related posts were showing up in the Add New & Edit post pages but not showing up on the published page.

    I am inserting the related posts directly into the post using:

    <?php if ( function_exists(‘related_posts’) ) : ?>
    <?php related_posts(); ?>
    <?php endif; ?>

    The beta 3.5.3b1 resolved the problem for me and everything is now fine.

    As for my setup, I’m using:

    1. WordPress 3.5.2
    2. Haven’t changed YARPP_CACHE_TYPE
    3. VPS running CentOS 5, PHP 5.2.17, MySQL 5.1.63-cll
    4. caching system – W3 Total Cache

    Hope this helps.

    NeverChill
    Member

    @neverchill

    Tried 3.5.3b1, now new posts don’t work until I flush the cache with YARPP Experiments. After that they pop right up.

    Hope this can point you in some direction.

    Plugin Author mitcho (Michael Yoshitaka Erlewine)
    Member

    @mitchoyoshitaka

    Thanks for all the feedback, everyone!

    @nhowarth glad 3.5.3b1 fixed your issues.

    I identified another possible way in which “no related posts” could occur incorrectly. This is fixed in 3.5.3b2. Please let me know if this new beta helps at all.

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.3b2.zip

    zenkaty
    Member

    @zenkaty

    Latest beta didn’t help me.

    I hadn’t heard of YARRP Experiments – I just downloaded it and flushed the cache, then tried to rebuild, and got this error: “There was an error while constructing the related posts for”

    Just tried the above @mitcho, still not working on my end either.

    Stuck with “No related articles found”

    Strange thing is its working locally but not live…..

    Will do some debugging later today and see if I can find anything, haven’t tried the YARPP experiments yet but may just mess around with the dbase.

    Will report back if I find anything

    zenkaty
    Member

    @zenkaty

    I have just updated WordPress to 3.4.2 – still no related posts.

    Interestingly, after I flushed the cache yesterday and tried to rebuild (failed at 0%) – it now says the cache is at 40.15%. I didn’t try to rebuild it, so not sure how that works. Maybe 40% of my posts have related posts… I haven’t been able to find any, though. It also says –

    Number related:
    0
    275

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Resolved] [Plugin: Yet Another Related Posts Plugin] No related posts’ is closed to new replies.