[Plugin: Yet Another Related Posts Plugin] No related posts (64 posts)

  1. @cperabo, @jacklabel, thanks for more information on your setups. @cperabo, I've just recently started hearing about bad interactions with SuperCache, which is unfortunate as I really like SuperCache and have recommended it to many. Moreover, I personally have not been able to reproduce these incompatibilities. :/

    @windows2000, the differences you note between YARPP on WP 2.7 and 2.8 are very interesting to me and also slightly worrisome... I have not been able to reproduce such differences. I just took an equivalent set of posts and metadata and built the YARPP cache on 2.7 and 2.8 and was able to build the exact same scores... are there any other salient differences between those two blogs you were testing?

  2. jacklabel
    Posted 6 years ago #

    And me?

  3. @jacklabel, was it ever working for you? Did you try @Azselendor's solution, to try updating a post? Does that work?

  4. Ahaenor
    Posted 6 years ago #

    Recently, i have the same issue as mentioned before. The related posts disapeared when i upgraded YARPP from 3.0.9 to 3.0.11.

    Version 2.1.6 works well, but it hasn't templates in it.

    PHP/MYSQL 5.0, WP 2.6.5, MyISAM on all tables, and not a single caching plugin. Updating posts don't help, and i've seen that score column in yarpp cache table has only 0 in it (recaching doesn't change it). The same 0-s was in the ID column.

    Seems like the ploblem is more fundamental than in caching plugins...

  5. @Ahaenor are you using the automatic display? The related_posts() in the template? Widget?

  6. Ahaenor
    Posted 6 years ago #

    are you using the automatic display? The related_posts() in the template? Widget?

    The list template, without widget.

  7. jacklabel
    Posted 6 years ago #

    Hi Micho,

    @jacklabel, was it ever working for you? Did you try @Azselendor's solution, to try updating a post? Does that work?

    Yes, was working for me. Try editing the page? Yes, I tried. Did not work. And the problem is in all posts. Not just a few.

    Please really need help. I want to continue using your plugin.

    What should I do now?

  8. Ahaenor
    Posted 6 years ago #

    I think the problem may be rooted in yarpp's caching system. Can templating version without caching be? Or, at least, with option to turn caching out.

    Many people here are telling that 2.1.6 works well, but it lack templates hardly.

    Only IMHO, of course.

  9. @Ahaenor - the new templating system is built on the caching system. The vast majority of users seem to have no problems with the caching.

    @jacklabel - I apologize but I can't think of any other thing to check. You may just have to use another plugin.

  10. juaron
    Posted 6 years ago #

    I seem to be having some of the same problems. I am running a copy of my blog on my localhost, where yarpp works just fine. In the online version however, all id's and scores in the yarpp_related_cache are 0.
    my confiugrations:
    local version (working):
    mysql 5.0.51a
    php 5.2.8
    wordpress 2.8.4
    yarpp 3.0.11

    online version (not working):
    mySQL 5.0.45
    php 5.1.6
    wordpress 2.8.4
    yarpp 3.0.11

    I only have a limited number of plugins installed; online the problem doesn't change when I activate only the ones I have running in my local version;
    - akismet
    - del.icio.us for WordPress
    - yarpp

  11. @juaron - so it's working on your local version but not the online one? What if you only activate those three plugins on the online version and rebuild the cache then?

  12. juaron
    Posted 6 years ago #

    @mitchoyoshitaka thanks for your reaction. I reaally appreciate it. I already tried to only activate the same plugins as in the local version. I've now also tried to deactivate all plugins but yarpp and to build te chache then. I always get the message that my cache status is ok, and when I rebuild the cache it tells me all went well. When I look at the values of the date field in the related_cache table, those do all change correctly when I do the update, so apparently the table is being updated, but maybe something goes wrong in calculating the relations?

    I also tried downgrading to v2.6.1 (with all other plugins deactivated) with no effect.

    By the way, the plugin used to work until some time ago, but I couldn't tell what I changed before it stopped working :(

  13. mjg
    Posted 6 years ago #

    Same as Ahaenor. YARPP stopped working about version 3.08.

    I reverted to 2.1.6 after reading this forum post and it works well. No caching plugin.

    Perhaps a conflict with another plugin? I've got too many to list here.

  14. genesteinberg
    Posted 6 years ago #

    OK, I have not been able to get this plugin to work, ever. I tried recent versions, and no luck.

    I'm able to use Efficient Related Posts no problem.


    My WP setup is as follows:

    Server software: Apache/2.2.13 (Unix) mod_ssl/2.2.13 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4
    Server name: http://www.technightowl.com
    Server address:
    Server port: 80

    PHP 5.2.10
    date 5.2.10
    zlib 1.1
    dom 20031129
    filter 0.11.0
    hash 1.0
    standard 5.2.10
    json 1.2.1
    mime_magic 0.1
    mysql 1.0
    SimpleXML 0.1
    Reflection 0.1
    SPL 0.2
    mysqli 0.1
    exif 1.4 $Id: exif.c,v 2009/05/28 14:03:09 pajoye Exp $
    tidy 2.0
    tokenizer 0.1
    xmlreader 0.1
    xmlrpc 0.51
    xmlwriter 0.1
    xsl 0.1
    zip 1.8.11
    suhosin 0.9.27
    PDO 1.0.4dev
    pdo_sqlite 1.0.1
    SQLite 2.0-dev
    pdo_mysql 1.0.2
    Zend Optimizer

    Plugin State Version URI
    404 SEO Plugin Active 1.5 http://www.404plugin.com
    Add to Any: Share/Bookmark/Email ButtonActive . http://www.addtoany.com/
    After The Deadline Active 0.4106 http://www.afterthedeadline.com
    Akismet Active 2.2.6 http://akismet.com/
    Anti-AdBlock Active 0.1.9 http://omninoggin.com/projects/wordpress-plugins/anti-adblock-wordpress-plugin/
    Broken Link Checker Inactive 0.5.9 http://w-shadow.com/blog/2007/08/05/broken-link-checker-for-wordpress/
    WP Calais Auto Tagger Active 1.2 http://www.dangrossman.info/wp-calais-auto-tagger
    Clean Options Inactive 1.2.2 http://www.mittineague.com/dev/co.php
    Cleanup WordPress Active 1.0.1 http://wiki.nisi.ro/wordpress/cleanup-wordpress-plugin/
    Comment Form Quicktags Active 1.1.7 http://rp.exadge.com/2009/01/08/comment-form-quicktags/
    DM Archives Inactive 1.0 http://www.nischalmaniar.info/wordpress
    Efficient Related Posts Active 0.3.2 http://xavisys.com/2009/06/efficient-related-posts/
    FeedBurner FeedSmith Active 2.3.1 http://www.feedburner.com/fb/a/help/wordpress_quickstart
    Find and replacer Inactive 1.6 http://www.wesg.ca/2008/08/wordpress-plugin-find-and-replacer/
    Google Analyticator Active 5.3.1 http://plugins.spiralwebconsulting.com/analyticator.html
    Google XML Sitemaps Active 3.1.6 http://www.arnebrachhold.de/redir/sitemap-home/
    jQuery-Pagebar Inactive 0.3.3 http://ocean90.wphelper.de/wordpress/plugin-jquery-pagebar/
    Limit Login Attempts Active 1.3.1 http://devel.kostdoktorn.se/limit-login-attempts
    PayPal Donations Active 1.4.1 http://coding.cglounge.com/wordpress-plugins/paypal-donations/
    Platinum SEO Pack Active 1.2.7 http://techblissonline.com/platinum-seo-pack/
    Search & Replace Inactive 2.5 http://bueltge.de/wp-suchen-und-ersetzen-de-plugin/114/
    Secure WordPress Active 0.3.9 http://bueltge.de/wordpress-login-sicherheit-plugin/652/
    Shockingly Big IE6 Warning Active 1.6.3 http://www.incerteza.org/blog/projetos/shockingly-big-ie6-warning/
    Fast and Secure Contact Form Active 1.5.1 http://www.642weather.com/weather/scripts-wordpress-si-contact.php
    Similarity Inactive 2.13.1 http://www.davidjmiller.org/2008/similarity/
    Simple Archive Generator Inactive 5.2 http://www.sterling-adventures.co.uk/blog/2007/10/01/simple-archive-plugin/
    Smart Archives Reloaded Active 1.6.1 http://scribu.net/wordpress/smart-archives-reloaded
    Snazzy Archives Inactive 1.3.2 http://www.prelovac.com/vladimir/wordpress-plugins/snazzy-archives
    Star Rating for Reviews Active 0.4 http://www.channel-ai.com/blog/plugins/star-rating/
    Stock Quote Sidebar Active 2.6 http://andy.hillhome.org/blog/code/stockquotesidebar
    Subscribe to Comments Now! Active 1.1.2 http://www.poradnik-webmastera.com/projekty/subscribe_to_comments_now/
    Subscribe To Comments Active 2.1.2 http://txfx.net/code/wordpress/subscribe-to-comments/
    System information Active 1.0 http://www.joeswebtools.com/wordpress-plugins/system-information/
    Twitter Posts Active 1.0.2 http://www.rene-ade.de/inhalte/wordpress-plugin-twitterposts.html
    Use Google Libraries Active http://jasonpenney.net/wordpress-plugins/use-google-libraries/
    FreeCharity.org.uk WordPress PetitionInactive 2.3.5 http://www.freecharity.org.uk/wordpress-petition-plugin/
    WP Ajax Edit Comments Active http://ajaydsouza.com/wordpress/plugins/wp-ajax-edit-comments/
    WP-DBManager Active 2.50 http://lesterchan.net/portfolio/programming/php/
    WP Email Guard Active 0.1 http://www.itquad.com/wordpress/plugins/wp-email-guard
    wp-mailfrom Active 0.3 http://wordpress.org/extend/plugins/wp-mailfrom/
    WP-Polls Inactive 2.50 http://lesterchan.net/portfolio/programming/php/
    WP-Print Active 2.50 http://lesterchan.net/portfolio/programming/php/
    WP-ServerInfo Inactive 1.50 http://lesterchan.net/portfolio/programming/php/
    WP Super Cache Active http://ocaoimh.ie/wp-super-cache/
    Wordpress Thread Comment Active http://blog.2i2j.com/plugins/wordpress-thread-comment
    WPtouch iPhone Theme Active http://bravenewcode.com/wptouch
    YANewsflash Plugin Active 1.0.3 http://www.stratos.me/wp-plugins/yanewsflash/

    Note that I disabled Efficient Related Posts and enabled yours before testing this.


  15. genesteinberg
    Posted 6 years ago #

    No idea? We have several WordPress installations. I tried it on another one, at http://www.technightowl.com/newsletter/ Got the excerpt part to function, with horrible formatting (everything run together with no separation). But no listed of related posts. We're not using a specially altered template, and I'm wondering if maybe trying it is a waste since support is clearly not very timely. :(


  16. badke
    Posted 6 years ago #

    After downloading the older version of YARPP that windows2000 posted, and using the custom options for the related_posts function, I was able to get it to work again.

    Using the older version by itself didn't work. I also deleted the tables the new version of YARPP creates, but I don't know if that has any impact on whether or not it worked.

    In my template I changed:

    <?php related_posts(); ?>


    <?php related_posts(array('title'=>1,'body'=>1,'tags'=>1,'categories'=>3)); ?>

    Obviously, if you're using the automatically display related posts option, you'll probably have to manually include the function in your template.

    The weird thing is, when I try to tell the function to consider title, body or tags (using 2 or 3) the function breaks at goes back to displaying "No related posts." The only array of options that works is 'title'=>1,'body'=>1,'tags'=>1,'categories'=>3.

  17. Gene, if you are expecting timely support, I recommend you find a paid solution for your issues. I try to check these forums once a week or so and improve YARPP in my limited spare time.

    @badke, I'm not sure what's going on there, but YARPP <3 is unsupported now so I won't be investigating that.

    To all else, I just had a family emergency and will be afk for a while.

  18. genesteinberg
    Posted 6 years ago #

    Listen, if you take the time to develop a plugin, you put yourself in a position to make at least an effort to provide support. If there are dozens of messages about people who can't get the thing to work when upgrading to the latest version, clearly there are issues you should investigate. You have to consider the time we put into trying these things out before either adopting them or giving them up.

    I'm sorry to hear of your family emergency. Certainly I understand how that impacts on the things you will be doing for a while.

    I hope, though, that when you get back, you'll consider how much people have spent investing their energies into using your product and maybe you'll be willing to provide a modicum of help when there are clearly serious issues. I mean, why should I pay someone else to fix your product? Are we serious.

    Gene Steinberg

  19. windows2000
    Posted 6 years ago #

    Gene, you need to step back and reevaluate the situation.

    You have not paid a dime to Mitcho, therefore you are not entitled to anything. Realize that he has ALREADY offered significant value for free, by writing, developing, and supporting the YARPP plugin. And here he is, responding to support in this forum. But for you, this is evidently not enough.

    The reality? His plugin is what it is, take it or leave it. Yes, it is disappointing when things don't work, but nobody has guaranteed support. When you obtain free software, you accept it "AS IS" and all risks become yours to bear.

    It would be nice when Mitcho's family emergency calms down, that he could diagnose the YARPP v3 bug causing "no related posts". But what gives you the right to *demand* that he does this? Be careful, or your attitude will drive free plugin authors to stop offering them altogether. After all, this is a giant net-loss for them. Disrespect their generosity too much, and perhaps it won't be worth their time any longer to develop.

    Give an inch and they take a mile, and all that... Sheesh.

  20. genesteinberg
    Posted 6 years ago #

    I am demanding nothing.

    But when lots of people report problems with a product, definitely the author needs to make a better effort to isolate the problem.

    As to risks: No risk on my part. If it doesn't work, and nobody can figure out why, I look for another solution.

    Only the author loses in the end. Consider, for example, if the author is accepting donations. Why donate hard-earned money to someone who has a product that isn't doing the job and isn't providing a reasonable level of support? You need to step back and think about the consequences of what you're saying and suggesting. You have it all backwards!


  21. Ahaenor
    Posted 6 years ago #

    I just give some insight to plugin's DB tables. In my case, the "wp_yarpp_keyword_cache" table is filled with normal data, but "wp_yarpp_related_cache" table's lines all have 0 values in "ID" and "score" fields.

    I tried to truncate this tables and to rebuild the cache data several times, but tables' data remains as i've mentioned before.

  22. Hi all—I'm back and am working on a diagnostic to add, as mentioned before, but I haven't gotten it working completely yet... it'll probably be in 3.0.14 beta 2.

    Thanks for all the feedback.

  23. juaron
    Posted 6 years ago #

    Glad to hear you're back. Thanks for putting the effort into this, and I hope it'll help solve the problem

  24. lzs
    Posted 6 years ago #

    Like many others I also have had problems upgrading from 2.1.4 to 3.0.4 (even up to the latest 3.0.13). There is always "No related posts". I really like YARP, but for now I have to go with Efficient Related Posts instead.

    I hope this bug gets sorted out, I'd love to come back to YARP.

  25. lzs
    Posted 6 years ago #

    Btw, for me, I found that there is a difference depending on which version of MySQL I run.

    With MySQL 4.1.7: YARP 2.1.4 works, YARP 3.0.13 does NOT work.
    With MySQL 5.0.45: YARP 2.1.4 works, YARP 3.0.13 works.

    Nothing else in the blog site changes. I just change wp-config.php to point to an alternate MySQL server I have on another system.

    I noted other people have reported problems even when their MySQL is of newer version than the 5.0.45 I have. So I'm not sure if this is an important finding or not.

  26. vkovalcik
    Posted 6 years ago #

    YARPP 3.0.9, 3.0.13 and 3.0.14b1 show "no related posts" to me too. The MySQL server is of a version 5.0.44. I am running WordPress 2.8.4 with some plug-ins including SuperCache. I've tried to disable it, but that doesn't help.

    As others pointed out, the wp_yarpp_related_cache table looks strange ... "reference_ID" column seems ok, but "ID" and "score" columns contains zeros in almost all of the positions (with the exception of one entry).

  27. Rhia42
    Posted 6 years ago #

    I installed YARPP and it worked great til I added another post and then it stopped working and I can't get it to work again. This is an automatic install, I did nothing manually. Only thing I did was add another category and checked that as well and then updated YARPP and it no longer works.

    Where do I find the wp_yarpp_related_cache table I see so many mention?


  28. vkovalcik
    Posted 6 years ago #

    Rhia42: You have to install phpMyAdmin, so you can view your database.

    Anyway, I think I am slowly starting to see the root of the problem on my system. Here is my hypothesis:
    The issue seems to be in the cache generation, more precisely: The queries that generate the yarpp_related_cache are sometimes timing out.
    I sometimes see the "Constructing the related posts timed out" message (I haven't seen that before this week), but it seems to me, that this is only shown for the first query. If the subsequent queries fail, the user won't know that (!) and the yarpp_related_cache table contains a lot of zeroes.

    In my case, this difference lies in the WPG2 plug-in, which significantly slows down certain operations. With this plug-in disable the cache generation of related posts takes about 30 seconds and yarpp_related_cache table contains those zeroes and a few valid numbers - these numbers are different every time I rebuild the cache, so I can see that it's not a simple software error (it would probably be the same every time).
    With the WPG2 deactivated, the generation takes about 4 seconds and all is ok. Of course, for different blogs, there might be different plug-ins that cause this slowdown.

    The solution might be to increase the waiting time, but I don't know exactly how to do it. I will try to guess it, but I am no PHP/Java/Ajax programmer, so it is a bit difficult for me (I am only experienced in C++/Pascal). Mitchoyoshitaka, could you help me, please?

    Aside from that, when I was examining the code, I found one possible inefficiency in yarpp_get_cached_keywords() function:

    $out = $wpdb->get_var("select $type from {$wpdb->prefix}yarpp_keyword_cache where ID = $ID");
    	if ($out === false or $out == '')
    	$out = $wpdb->get_var("select $type from {$wpdb->prefix}yarpp_keyword_cache where ID = $ID");

    should probably be:

    $out = $wpdb->get_var("select $type from {$wpdb->prefix}yarpp_keyword_cache where ID = $ID");
    	if ($out === false or $out == '') {
    	  $out = $wpdb->get_var("select $type from {$wpdb->prefix}yarpp_keyword_cache where ID = $ID");
  29. vkovalcik
    Posted 6 years ago #

    I stand corrected, the main problem wasn't the timeout. But I found a solution (that works for me at least) :)

    It can be fixed as follows. All done in 3.0.14b1, file magic.php. Replace line 212, originally:
    $newsql .= " having score >= $safethreshold";
    with this:
    $newsql .= " having score >= " . number_format($safethreshold, 2, '.', '');

    Explanation: It was a "localization bug". The original line generated SQL select with
    "... having score >= 0,5 ..."
    which is correct in my language (Czech), but incorrect in English and SQL. The second statement will generate
    "... having score >= 0.5 ..."
    Surprisingly, this happens only when WPCG2 plugin is active, which probably means that WP itself works in neutral language and WPG2 switched the context somehow - the problem might be in WPG2, but I guess the same problem happens with some other plugins.

    Hope it will help you!

  30. demaine
    Posted 6 years ago #

    I am also having the same problem as everyone else on here. This plugin was working fine for me and worked really well but then all of a sudden it cannot find any related posts at all even on pages which previously had been seen to have related posts. I have tried everything suggested here (within my capabilities) but with no joy. To be honest I didn't realise it had stopped working so I don't know how long it has been like this. The only thing I can think of is whether one of the recent updates to WordPress have somehow affected the plugin because for me that is all that has changed but then if the author doesn't suffer the same problems I am at a complete loss here.
    I would really like to continue using the plugin if a solution can be found otherwise I need to find a more stable alternative which will do the same job.

Topic Closed

This topic has been closed to new replies.

About this Topic