Support » Plugins » [Plugin: Yet Another Related Posts Plugin] No related posts

  • I can’t get the YARPP plugin to work. I’m running WP 2.8 and 3.0.6. Just upgraded both WP and the plugin yesterday, which is when it stopped working. It worked great before. The server is running PHP5 and MySQL 5.0.45.

    I read through the FAQ and the forums to try and figure out what’s going on, but still can’t get it working. When I re-build the cache, then return to the YARPP options page, it shows the cache at 0%. The build on the fly option is enabled.

    Any help would be appreciated.

Viewing 15 replies - 16 through 30 (of 63 total)
  • I see many people with the same problem (must be a general problem), but i see no more responses from the developer. We must forget the plugin?

    @badke, no, the firewall shouldn’t be an issue. That yarpp_related_cache makes it look like the cache was built but none of the posts found any related posts. You can try clearing that table, making sure the “on the fly” caching option is on, and visiting one of your pages and seeing what it says.

    Hi @jacklabel, I’m right here. πŸ™‚

    Hi Mitcho.

    I have the same problem above. The plugin worked perfectly. Then stopped working. Shows only ‘no-related posts’. Already changed the filter to 0.1 and the problem keep. Already cleaned the php and nothing. Already rebuilt the cache and nothing.

    I do not know what was the problem. Perhaps to some update of wordpress.
    I do not know else to do. Can you help me?

    I am also having the same problem. I turned threshold down to 0.5, rebuilt the cache. Still getting No Related Posts.

    Using WordPress 2.7.1
    and YARPP 3.0.8

    same issue here, i’m sad because of it.

    Just getting “no related posts”.

    To all of you not getting related postsβ€”

    I’m having a hard time reproducing this situation, and it seems that it “just works” for the vast majority of users. Please tell me what PHP, MySQL, WP, and YARPP versions you are using. Please verify that both YARPP tables and your wp_posts table are using the MyISAM engine.

    Other information like “it was working until I did X” is helpful. Also, if you could look at your wp_yarpp_related_cache table and see if there are any entries at all or any entries with related_ID != 0, I would appreciate that.

    PHP 5.2.10
    MySQL 5.0.45
    WordPress 2.8.0
    YARPP 3.0.8

    The YARPP tables were MyISAM, but the rest of the WordPress tables were InnoDB. I made a backup of my database, made a new one with it, and changed all the tables to MyISAM. Didn’t help.

    Also, in regards to your post from 3 days ago… I deleted all entries in the related cache table, and made sure compute on the fly was enabled (which it was). Still nothing. All of the related_ID’s were 0 before I did that.

    This all happened when I went from WP 2.7.x to 2.8.0. After that upgrade, I immediately updated all plugins, including YARPP (to 3.0.6). Not sure which version of YARPP I upgraded from.

    I never checked a post after upgrading WP, so I’m not sure if it broke after the WP upgrade or after the YARPP upgrade.

    @badke – YARPP needs your wp_posts table to be MyISAM and then needs to create a few indices on it. You’ll want to (1) make wp_posts MyISAM, (2) go to the YARPP options page so it creates those indices, and (3) dump wp_yarpp_related_cache. Please try that.

    Hi Mitcho:

    PHP: 5.2.8
    MySQL: 5.0.77
    WordPress: 2.8.3
    YARPP: 3.0.9

    All in MyISAM engine. I dont know when the problem began. But the plugin worked well before.

    I do not understand very well their application on related_ID! = 0, because i do not understand PHP. But in wp_yarpp_related_cache there is a column called ID with all values equal to 0

    What should I do?


    I think this was already suggested, but I was having the same/similar problem until I went in an edited a page that said “no related posts”. Now there are related posts on that page.

    Now I’m in the process of hitting “update page” on every post and page for it to work properly.

    Hey Mitcho… Will you help us? There are many people waiting for your response…

    Hey guys do you all have 2.8? I have two test blogs, one with 2.7.1 and another with 2.8.3. Both xampplite 1.7.1 basically, which is PHP 5.2.9, MySQL 5.1.33, and YARPP 3.0.8 and 3.0.9.

    The WP 2.7.1 blog has a lot of posts and Related Posts works well. When I view the wp_yarpp_related_cache for this blog, the Score values are healthy. ALL are >= 1. Most are in the 2-5 range.

    In my WP 2.8.3 blog, it has a few posts but more Pages than posts. The wp_yarpp_related_cache for this blog has Score values that don’t look very healthy at all, despite a high level of Relatedness. The Score is mostly < 1 with some that are 0! Most are between 0.5-0.9, but some are 17-19. For the 17-19, they work properly and show as Related Posts.

    But why doesnt it work nearly as well as my WP 2.7.1 blog? I even hand edited the posts (on the WP 2.8.3) so they have the same Categories and Tags, thinking this would increase the Relatedness to “kick start” the Related Posts action. No dice.

    Of course I have tried rebuilding the Cache about 100 times and it doesnt help. I am not using any SuperCache plugins at the moment, either.

    I am willing to do whatever it takes to solve this issue and get YARPP 3.0 working properly. Thank you for this nice plugin.

    EDIT: Since so many people have commented about 2.1.6 working in the past, I located this old version:

    Wow! Instant success! 2.1.6 works like a charm right out of the box. It’s a shame it doesn’t have the high performance caching system of v3.0 but at least it works.

    I am sad πŸ™ but getting happier! πŸ™‚

    Today I updated my WP to Version 2.8.4 (from 2.8.2) today and along with it my YARPP to version 3.0.9 (can’t remember what version I had, but likely 3.x).

    I tried EVERYTHING mentioned here, clearing caches, reducing the match threshold, reinstalling, older versions, newer versions, you name it… and stayed sad.

    Not only was I not getting related posts, but I wasn’t even getting the not “No related posts”. Worse still, from my blog Homepage, i will click on posts and get “Uh oh. Sorry, no posts matched your criteria”. Finally, my sidebar that normally has the related posts also wasn’t showing up.

    Finally after deactivating all the plugin one by one, I stumbled upon something strange. If I activated WP-cache (version 2.1.2) or WP Super Cache (Version then my related posts would just “disappear”.

    I uninstalled version 3.0.9 and installed 2.1.6 and it worked ok. I’m going to try insatlling newer versions and hope I can get closer to all the features 3.0.9 offers without “disappearing”.

    @cperabo, @jacklabel, thanks for more information on your setups. @cperabo, I’ve just recently started hearing about bad interactions with SuperCache, which is unfortunate as I really like SuperCache and have recommended it to many. Moreover, I personally have not been able to reproduce these incompatibilities. :/

    @windows2000, the differences you note between YARPP on WP 2.7 and 2.8 are very interesting to me and also slightly worrisome… I have not been able to reproduce such differences. I just took an equivalent set of posts and metadata and built the YARPP cache on 2.7 and 2.8 and was able to build the exact same scores… are there any other salient differences between those two blogs you were testing?

Viewing 15 replies - 16 through 30 (of 63 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] No related posts’ is closed to new replies.