WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Yet Another Related Posts Plugin] No related posts

[Plugin: Yet Another Related Posts Plugin] No related posts

  • I can’t get the YARPP plugin to work. I’m running WP 2.8 and 3.0.6. Just upgraded both WP and the plugin yesterday, which is when it stopped working. It worked great before. The server is running PHP5 and MySQL 5.0.45.

    I read through the FAQ and the forums to try and figure out what’s going on, but still can’t get it working. When I re-build the cache, then return to the YARPP options page, it shows the cache at 0%. The build on the fly option is enabled.

    Any help would be appreciated.

Viewing 15 replies - 1 through 15 (of 63 total)
  • Help?

    It works great with me, using wp2.8 and the lastest version
    You should check your current plugin

    badke, it sounds like you have the requirements to use the plugin covered… Do you get any errors? Are you getting the “no related posts” message on your posts, or no text at all?

    Having the same problems.

    WordPress 2.8.2

    Started with 3.0.6 and noticed “No related posts.” checked for update and setup 3.0.8b2 and still cannot get any related posts to show.

    As badke said, mine was also working fine prior to updating.

    Been trying to resolve this for a few hours now with no luck.

    Also as further confirmation even when logged into ADMIN and under posts.

    These are the related entries for this entry. Updating this post may change these related posts.

    None of the posts under WordPress – Admin – Posts show related.

    @degrama – what you describe is a different issue than what was described above… could you check your wp_yarpp_related_cache table and see if there’s anything in it? You can try clearing it as well and rebuilding the cache.

    I’m having the same issue –
    yarpp 3.0.7 wp 2.8.2, was working well, until I changed a value in relatedness and rebuilt database using the admin panel button.
    After that, “No related posts” displayed by widget.

    I’ve checked wp_yarpp_related_cache – it had lots of data. I deleted all data from wp_yarpp_related_cache and wp_yarpp_keyword_cache
    build on the fly option enabled.
    and still “No related posts” displayed by widget.

    Grateful for any help! -Roger

    Roger, that is odd indeed. Did you try the beta release I mentioned above?

    Mitcho – Thanks for your reply – today I tried the beta you mentioned and 3.0.8b4 – same problem with both.
    I also reverted the back to your standard settings and CSS, but still no luck.
    It’s a shame because the plugin looks really good, the customisable CSS is great. If only it would display the related posts 🙂

    Roger, you said it was working before for you?

    I’m running version WP 2.8, yet-another-related-posts-plugin 3.0.8 is not working !I isntalled by your instruction.

    Its always show like this :These are the related entries for this entry. Updating this post may change these related posts.

    No related posts.

    Thanks for your support

    htv7, ah, that’s the display on the edit post screen… how about on the post itself, though, when you view it? Does it display there?

    I’m having the same problem – WP 2.8.2 and have tried both YARPP 3.0.8 and 3.0.8b2..

    Everything seems to be in good order, but the result is always the “No Related Post” (or, “No related photos” when the photo template is selected) displayed on the post page.

    I have tried :
    – rebuilding the cache (several times)
    – dropping the match threshold to 1 and then .05
    – selecting “do not consider” for all except “consider: category”

    [note: the ideal setting for this photo portfolio blog would be “require at least one category in common” and nothing else, where the common category is the photo category]

    The text “No Related Photos” DOES appear at the end of each post – but there are at least 9 other posts/photos in each category, so those related posts should be displayed.

    Any suggestions?
    Thank you!

    @mitchoyoshitaka, tried using 3.0.8b2, 3.0.8b4 and the latest stable version (updated through WP) — since I haven’t tried anything in a few weeks.

    Still having the same problem.

    We have a firewall setup on our server, would there have been any changes that 3.0.6 made that could possibly be blocked by a firewall? Seems like a stretch, but figured I’d throw it out there. Like I mentioned originally, the plugin was working great before the upgrades.

    Any suggestions for tests that could be run to see where the problem is? Anything I could look for the in the database to see if there’s a problem there?

    Looking at the tables in the database, yarpp_related_cache has reference_ID’s, both has nothing but 0’s for the ID and score.

Viewing 15 replies - 1 through 15 (of 63 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] No related posts’ is closed to new replies.