The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[Plugin: Yet Another Related Posts Plugin] No related posts (64 posts)

  1. badke
    Posted 7 years ago #

    I can't get the YARPP plugin to work. I'm running WP 2.8 and 3.0.6. Just upgraded both WP and the plugin yesterday, which is when it stopped working. It worked great before. The server is running PHP5 and MySQL 5.0.45.

    I read through the FAQ and the forums to try and figure out what's going on, but still can't get it working. When I re-build the cache, then return to the YARPP options page, it shows the cache at 0%. The build on the fly option is enabled.

    Any help would be appreciated.

  2. badke
    Posted 7 years ago #


  3. Funnnny
    Posted 7 years ago #

    It works great with me, using wp2.8 and the lastest version
    You should check your current plugin

  4. badke, it sounds like you have the requirements to use the plugin covered... Do you get any errors? Are you getting the "no related posts" message on your posts, or no text at all?

  5. Degrama
    Posted 7 years ago #

    Having the same problems.

    WordPress 2.8.2

    Started with 3.0.6 and noticed "No related posts." checked for update and setup 3.0.8b2 and still cannot get any related posts to show.

    As badke said, mine was also working fine prior to updating.

    Been trying to resolve this for a few hours now with no luck.

    Also as further confirmation even when logged into ADMIN and under posts.

    These are the related entries for this entry. Updating this post may change these related posts.

    None of the posts under WordPress - Admin - Posts show related.

  6. @Degrama - what you describe is a different issue than what was described above... could you check your wp_yarpp_related_cache table and see if there's anything in it? You can try clearing it as well and rebuilding the cache.

  7. roggie
    Posted 7 years ago #

    I'm having the same issue -
    yarpp 3.0.7 wp 2.8.2, was working well, until I changed a value in relatedness and rebuilt database using the admin panel button.
    After that, "No related posts" displayed by widget.

    I've checked wp_yarpp_related_cache - it had lots of data. I deleted all data from wp_yarpp_related_cache and wp_yarpp_keyword_cache
    build on the fly option enabled.
    and still "No related posts" displayed by widget.

    Grateful for any help! -Roger

  8. Roger, that is odd indeed. Did you try the beta release I mentioned above?

  9. roggie
    Posted 7 years ago #

    Mitcho - Thanks for your reply - today I tried the beta you mentioned and 3.0.8b4 - same problem with both.
    I also reverted the back to your standard settings and CSS, but still no luck.
    It's a shame because the plugin looks really good, the customisable CSS is great. If only it would display the related posts :)

  10. Roger, you said it was working before for you?

  11. htv7
    Posted 7 years ago #

    I'm running version WP 2.8, yet-another-related-posts-plugin 3.0.8 is not working !I isntalled by your instruction.

    Its always show like this :These are the related entries for this entry. Updating this post may change these related posts.

    No related posts.

    Thanks for your support

  12. htv7, ah, that's the display on the edit post screen... how about on the post itself, though, when you view it? Does it display there?

  13. invisiblepilot
    Posted 7 years ago #

    I'm having the same problem - WP 2.8.2 and have tried both YARPP 3.0.8 and 3.0.8b2..

    Everything seems to be in good order, but the result is always the "No Related Post" (or, "No related photos" when the photo template is selected) displayed on the post page.

    I have tried :
    - rebuilding the cache (several times)
    - dropping the match threshold to 1 and then .05
    - selecting "do not consider" for all except "consider: category"

    [note: the ideal setting for this photo portfolio blog would be "require at least one category in common" and nothing else, where the common category is the photo category]

    The text "No Related Photos" DOES appear at the end of each post - but there are at least 9 other posts/photos in each category, so those related posts should be displayed.

    Any suggestions?
    Thank you!

  14. badke
    Posted 7 years ago #

    @mitchoyoshitaka, tried using 3.0.8b2, 3.0.8b4 and the latest stable version (updated through WP) -- since I haven't tried anything in a few weeks.

    Still having the same problem.

    We have a firewall setup on our server, would there have been any changes that 3.0.6 made that could possibly be blocked by a firewall? Seems like a stretch, but figured I'd throw it out there. Like I mentioned originally, the plugin was working great before the upgrades.

    Any suggestions for tests that could be run to see where the problem is? Anything I could look for the in the database to see if there's a problem there?

  15. badke
    Posted 7 years ago #

    Looking at the tables in the database, yarpp_related_cache has reference_ID's, both has nothing but 0's for the ID and score.

  16. jacklabel
    Posted 7 years ago #

    I see many people with the same problem (must be a general problem), but i see no more responses from the developer. We must forget the plugin?

  17. @badke, no, the firewall shouldn't be an issue. That yarpp_related_cache makes it look like the cache was built but none of the posts found any related posts. You can try clearing that table, making sure the "on the fly" caching option is on, and visiting one of your pages and seeing what it says.

  18. Hi @jacklabel, I'm right here. :)

  19. jacklabel
    Posted 7 years ago #

    Hi Mitcho.

    I have the same problem above. The plugin worked perfectly. Then stopped working. Shows only 'no-related posts'. Already changed the filter to 0.1 and the problem keep. Already cleaned the php and nothing. Already rebuilt the cache and nothing.

    I do not know what was the problem. Perhaps to some update of wordpress.
    I do not know else to do. Can you help me?

  20. hbkdinobot
    Posted 7 years ago #

    I am also having the same problem. I turned threshold down to 0.5, rebuilt the cache. Still getting No Related Posts.

    Using WordPress 2.7.1
    and YARPP 3.0.8

  21. konvct
    Posted 7 years ago #

    same issue here, i'm sad because of it.

    Just getting "no related posts".

  22. To all of you not getting related posts—

    I'm having a hard time reproducing this situation, and it seems that it "just works" for the vast majority of users. Please tell me what PHP, MySQL, WP, and YARPP versions you are using. Please verify that both YARPP tables and your wp_posts table are using the MyISAM engine.

    Other information like "it was working until I did X" is helpful. Also, if you could look at your wp_yarpp_related_cache table and see if there are any entries at all or any entries with related_ID != 0, I would appreciate that.

  23. badke
    Posted 7 years ago #

    PHP 5.2.10
    MySQL 5.0.45
    WordPress 2.8.0
    YARPP 3.0.8

    The YARPP tables were MyISAM, but the rest of the WordPress tables were InnoDB. I made a backup of my database, made a new one with it, and changed all the tables to MyISAM. Didn't help.

    Also, in regards to your post from 3 days ago... I deleted all entries in the related cache table, and made sure compute on the fly was enabled (which it was). Still nothing. All of the related_ID's were 0 before I did that.

    This all happened when I went from WP 2.7.x to 2.8.0. After that upgrade, I immediately updated all plugins, including YARPP (to 3.0.6). Not sure which version of YARPP I upgraded from.

    I never checked a post after upgrading WP, so I'm not sure if it broke after the WP upgrade or after the YARPP upgrade.

  24. @badke - YARPP needs your wp_posts table to be MyISAM and then needs to create a few indices on it. You'll want to (1) make wp_posts MyISAM, (2) go to the YARPP options page so it creates those indices, and (3) dump wp_yarpp_related_cache. Please try that.

  25. jacklabel
    Posted 7 years ago #

    Hi Mitcho:

    PHP: 5.2.8
    MySQL: 5.0.77
    WordPress: 2.8.3
    YARPP: 3.0.9

    All in MyISAM engine. I dont know when the problem began. But the plugin worked well before.

    I do not understand very well their application on related_ID! = 0, because i do not understand PHP. But in wp_yarpp_related_cache there is a column called ID with all values equal to 0

    What should I do?


  26. Hraedran Azselendor
    Posted 7 years ago #

    I think this was already suggested, but I was having the same/similar problem until I went in an edited a page that said "no related posts". Now there are related posts on that page.

    Now I'm in the process of hitting "update page" on every post and page for it to work properly.

  27. jacklabel
    Posted 7 years ago #

    Hey Mitcho... Will you help us? There are many people waiting for your response...

  28. windows2000
    Posted 7 years ago #

    Hey guys do you all have 2.8? I have two test blogs, one with 2.7.1 and another with 2.8.3. Both xampplite 1.7.1 basically, which is PHP 5.2.9, MySQL 5.1.33, and YARPP 3.0.8 and 3.0.9.

    The WP 2.7.1 blog has a lot of posts and Related Posts works well. When I view the wp_yarpp_related_cache for this blog, the Score values are healthy. ALL are >= 1. Most are in the 2-5 range.

    In my WP 2.8.3 blog, it has a few posts but more Pages than posts. The wp_yarpp_related_cache for this blog has Score values that don't look very healthy at all, despite a high level of Relatedness. The Score is mostly < 1 with some that are 0! Most are between 0.5-0.9, but some are 17-19. For the 17-19, they work properly and show as Related Posts.

    But why doesnt it work nearly as well as my WP 2.7.1 blog? I even hand edited the posts (on the WP 2.8.3) so they have the same Categories and Tags, thinking this would increase the Relatedness to "kick start" the Related Posts action. No dice.

    Of course I have tried rebuilding the Cache about 100 times and it doesnt help. I am not using any SuperCache plugins at the moment, either.

    I am willing to do whatever it takes to solve this issue and get YARPP 3.0 working properly. Thank you for this nice plugin.

    EDIT: Since so many people have commented about 2.1.6 working in the past, I located this old version: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.2.1.6.zip

    Wow! Instant success! 2.1.6 works like a charm right out of the box. It's a shame it doesn't have the high performance caching system of v3.0 but at least it works.

  29. cperabo
    Posted 7 years ago #

    I am sad :( but getting happier! :)

    Today I updated my WP to Version 2.8.4 (from 2.8.2) today and along with it my YARPP to version 3.0.9 (can't remember what version I had, but likely 3.x).

    I tried EVERYTHING mentioned here, clearing caches, reducing the match threshold, reinstalling, older versions, newer versions, you name it... and stayed sad.

    Not only was I not getting related posts, but I wasn't even getting the not "No related posts". Worse still, from my blog Homepage, i will click on posts and get "Uh oh. Sorry, no posts matched your criteria". Finally, my sidebar that normally has the related posts also wasn't showing up.

    Finally after deactivating all the plugin one by one, I stumbled upon something strange. If I activated WP-cache (version 2.1.2) or WP Super Cache (Version then my related posts would just "disappear".

    I uninstalled version 3.0.9 and installed 2.1.6 and it worked ok. I'm going to try insatlling newer versions and hope I can get closer to all the features 3.0.9 offers without "disappearing".

Topic Closed

This topic has been closed to new replies.

About this Topic