Support » Plugins » [Plugin: Yet Another Related Posts Plugin] False MyISAM Warning

  • I have v. 2.1 of the plugin and am running the latest v. 2.6 of WordPress. I am getting the “Your database’s wp_posts table is not set up to use the MyISAM storage engine which is required for YARPP to use the “consider titles” and “consider bodies” criteria. These two options have been disabled.” warning even though my wp-posts table is in fact set up to use MyISAM. I ran the recommended SQL command anyway, cleared my cookies, cleared my cache and nothing seems to work. Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • @jewlicious – Hm… the way this check works is by running a show table status query and checking the Engine column. There is a possibility that the MySQL user you use to let WP access your database doesn’t have the SHOW privilege, and thus can’t run that query… what do you think?

    In any case, if things are working and running the ALTER query doesn’t alter anything, you’re fine continuing to use the plugin even with that warning… I apologize for the false positive.


    Thread Starter DaveyWavey


    Thanks for the response. Yes, I can continue to run the plugin BUT I can’t have it consider post contents which makes the results quite a bit wonky. My blog is 4 years old with 4 thousand posts most of which don’t have tags.

    I checked my database via phpMyAdmin and all my tables are set to run under MyISAM. There is only one database user with full privileges so your scenario is not the solution.

    I mean it’s a great plugin and I’d like very much to use it but, well… this is a problem!


    Just downloaded and installed your (superb) plugin on a 2.6.x WP install and I have exactly the same problem and Jewlicious with the same scenario (the WP DB user for MySQL DB has full permissions on the DB, and I ran the ISAM Alter Table command succesfully) …

    Any thoughts on this ?



    I’m getting the same problem too – WP 2.6.3, plugin 2.1 . Is there any way I can hamstring the “check for MyISAM” bit so it keeps working regardless?

    I’ve done a bit of debugging, by digging around in the yarpp_myisam_check() function in includes.php.

    The function reads the posts table’s status into $table OK, but $table->Engine returns a NULL. Maybe it’s a MySQL issue? If so, perhaps the plugin should say something like “I can’t determine the engine you’re using, make sure it’s MyISAM if you want to use post contents/titles”

    Anyway, to answer my previous question – yes there is a way to disable this check.

    If you’re getting this message, and you’re SURE your table actually IS running on MyISAM, then here’s a fast-and-dirty fix:

    You need to edit the file includes.php in the YARPP plugin’s directory. Go down to line 89 which should read

    function yarpp_myisam_check() {

    Immediately after this line, add a new one saying

    return 1;

    This will make the function return true regardless of what MySQL might (not) say. Hopefully this issue will be fixed properly in a new release…

    @chunt – thanks for helping some others out with this while I wasn’t watching… I appreciate it.

    I’m still not sure why I’m getting weird results for the Engine values… I myself checked on a few different servers before I released this version and it was accurately identify the Engine…

    In the future I’ll probably give a message like you say “I can’t determine the engine” in the case where it can’t, or otherwise actually display the result it’s getting for the Engine, which will help in debugging further issues such as this.

    Thanks again!


    Hi all–

    I just wanted to mention that the new version of the plugin, 2.1.2, includes an option to override the MyISAM check, so you can go ahead and use those MyISAM features anyway, in case the check fails. Take a look!

    Thanks for all your feedback!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] False MyISAM Warning’ is closed to new replies.