Support » Plugins and Hacks » [Plugin: Yet Another Related Posts Plugin] Error: . . function include . . . failed

  • riverwriter

    (@riverwriter)


    Using WordPress 2.7.1

    I have updated YARPP to 3.0.2 using the automatic plugin update feature. I am using it with Print this Post plugin. I have asterisked out the directory below. The site is http://riverwriter.ca/wordcurrents/

    Error message for the past few days (before recent updates and since):
    Warning: include(/home/riverwri/public_html/wordcurrents/wp-content/themes/inanis-glass1.3/) [function.include]: failed to open stream: Success in /home/riverwri/public_html/wordcurrents/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 300

    Warning: include() [function.include]: Failed opening ‘/home/******/public_html/wordcurrents/wp-content/themes/inanis-glass1.3/’ for inclusion (include_path=’.:/usr/lib/php’) in /home/******/public_html/wordcurrents/wp-content/plugins/yet-another-related-posts-plugin/magic.php on line 300

Viewing 6 replies - 1 through 6 (of 6 total)
  • This was fixed in 3.0.1… are you sure these pages aren’t getting cached somehow? I heard that happened to someone else as well.

    Additionally, try going to the YARPP options page and saving the options (even if you don’t change anything). That may also fix it.

    neofreko

    (@neofreko)

    In this the error in line 300?

    YARPP doesn’t check whether user has empy template_file variable. Should have been like this:

    } elseif ($use_template and !empty($template_file) && file_exists(STYLESHEETPATH . '/' . $template_file)) {

    @neofreko – I made that change in 3.0.1 but it accidentally did not get rolled into 3.0.2. It’ll be in the next release.

    freakingwildchild

    (@freakingwildchild)

    @mitchoyoshitaka: There seem to be a lot of sites suffering from this line 300 bug; search google for the error and you’ll find dozens of them..

    I’m glad neofreko offered the solution.

    @freakingwildchild – the solution was already in 3.0.1. I just uploaded 3.0.3 which will include the fix as well.

    riverwriter

    (@riverwriter)

    That fixed it. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Error: . . function include . . . failed’ is closed to new replies.